Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [PATCH] fix mx btl_bandwidth
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2010-09-04 12:25:30


Le 03/09/2010 17:33, George Bosilca a écrit :
>>> GM 250 NO Doubtful
>>>

This one should be 2000 (assuming nobody runs Myrinet 1280 from the 90s
anymore :))

>>> MX 2000/10000 YES (Mbs) Correct (before the patch)
>>> OFUD 800 NO Doubtful
>>> OpenIB 2000/4000/8000 YES (Mbs) Correct (multiplied by the active_width)
>>>
>>>
>> I found the problem when using both MX and OpenIB at the same time, so
>> they can't be both wrong or both correct. IB was reporting 800, not
>> 2000/4000/8000. Maybe because auto-detect didn't work and the default is
>> wrong:
>> btl_openib_mca.c:527: mca_btl_openib_module.super.btl_bandwidth = 800;
>>
> It appears that Open IB only auto-detect the bandwidth if the value is explicitly set to zero via the mca parameters. As a last resort: as for the other devices you can set it manually. Use something like btl_openib_bandwidth_%dev_name% to set the bandwidth per device.
>

Ah thanks, it helps a lot. I added a similar mca parameter to tune the
MX/Open-MX bandwidth as well, and I can tune averything I want now.

By the way, why is IB auto-detect disabled by default?

Brice