Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] OMPI 1.5 twitter notification plugin probably broken by switch to OAUTH
From: Ralph Castain (rhc_at_[hidden])
Date: 2010-09-01 12:03:12


I'm afraid that triggering a notifier message isn't that simple - instances where notifier is invoked are still rare in the code base.

I'll be adding some to the developer's trunk shortly that will provide a better test (i.e., will trigger on things like failed-to-launch). Will let you know when they are available!

On Sep 1, 2010, at 5:15 AM, Chris Samuel wrote:

> Hi folks,
>
> Looking at the code for the Twitter notifier in OMPI 1.5
> and seeing its use of HTTP basic authentication I would
> suggest that it may be non-functional due to Twitters
> switch to purely OAUTH based authentication for their API.
>
> I'm trying to test it out here but I'm at a bit of a loss
> to find a trivial command line to trigger a notifier, even
> the syslog one! I've Googled and grep'd with no joy..
>
> For instance:
>
> chris_at_quad:/tmp/ompi$ ./bin/mpirun --mca notifier syslog --mca notifier_threshold_severity 99 --mca
> notifier_base_verbose 99 /bin/doesnotexist
> [quad:18429] mca: base: components_open: Looking for notifier components
> [quad:18429] mca: base: components_open: opening notifier components
> [quad:18429] mca: base: components_open: found loaded component syslog
> [quad:18429] mca: base: components_open: component syslog has no register function
> [quad:18429] mca: base: components_open: component syslog open function successful
> [quad:18429] mca:base:select: Auto-selecting notifier components
> [quad:18429] mca:base:select:(notifier) Querying component [syslog]
> [quad:18429] mca:base:select:(notifier) Query of component [syslog] set priority to 1
> [quad:18429] mca:base:select:(notifier) Selected component [syslog]
> --------------------------------------------------------------------------
> mpirun was unable to launch the specified application as it could not access
> or execute an executable:
>
> Executable: /bin/doesnotexist
> Node: quad
>
> while attempting to start process rank 0.
> --------------------------------------------------------------------------
> [quad:18429] mca: base: close: component syslog closed
> [quad:18429] mca: base: close: unloading component syslog
>
> But nothing appears in the syslog.
>
> Ideas ?
>
> cheers!
> Chris
> --
> Christopher Samuel Senior Systems Administrator
> VLSCI - Victorian Life Sciences Computational Initiative
> Email: samuel_at_[hidden] Phone: +61 (0)3 903 55545
> http://www.vlsci.unimelb.edu.au/
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel