Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI devel] "make check" (libtool?) failure on Solaris/SPARC (1.5rc5 and 1.4.3rc1)
From: Paul H. Hargrove (PHHargrove_at_[hidden])
Date: 2010-08-26 16:14:22


Paul H. Hargrove wrote:
>
> Ralf Wildenhues wrote:
>> Hello Paul,
>>
>> * Paul H. Hargrove wrote on Thu, Aug 26, 2010 at 01:58:11AM CEST:
>>
>>> I have been able to configure and build both 1.5rc5 and 1.4.3rc1 on
>>> Solaris 10 for SPARC, using Sun C 5.10.
>>> I have also build 1.5rc5 w/ gcc-3.3.2 (and expect 1.4.3rc1 to build
>>> w/ gcc as well, once I have time)
>>>
>>> All 3 builds fail "make check" in a way that suggests to me that
>>> libtool is not working correctly on this platform.
>>>
>>
>> Can you send output of './libtool --config' for the platforms?
>>
>> Thanks,
>> Ralf
>>
>
> Requested output is attached.
>
> -Paul
>

Ralph,

  I just had a thought on this one: In my environment on this platform
I have LD_LIBRARY_PATH_32 and LD_LIBRARY_PATH_64 set. It seems possible
to me that this is causing the loader to ignore the LD_LIBRARY_PATH
setting that libtool's wrapper script sets when executing uninstalled
programs in the build directory, as during "make check".
  So, I tried removing these from my environment and editing ~/.bashrc
not to set them. The result is a SUCCESSful "make check"!

-Paul

-- 
Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
HPC Research Department                   Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900