Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] delivering SIGUSR2 to an ompi process
From: Steve Wise (swise_at_[hidden])
Date: 2010-08-25 13:26:21


On 08/25/2010 11:33 AM, Ralph Castain wrote:
> We don't use it - mpirun traps it and then propagates it by default to all remote procs.
>
>

So I should send the signal to the mpirun process?

> What OMPI version is this?
>
>

1.4.1

> On Aug 25, 2010, at 10:23 AM, Steve Wise wrote:
>
>
>> Hey Open MPI wizards,
>>
>> I'm trying to debug something in my library that gets loaded into my mpi processes when they are started via mpirun. With other MPIs, I've been able to deliver SIGUSR2 to the process and trigger some debug code I have in my library that sets up a handler for SIGUSR2. However, when I deliver SIGUSR2 to my process running under OMPI, the process just dies and mpirun logs this:
>>
>> --------------------------------------------------------------------------
>> mpirun noticed that process rank 0 with PID 13568 on node hpc-cn2 exited on signal 12 (User defined signal 2).
>> --------------------------------------------------------------------------
>>
>>
>> Is there any way to allow SIGUSR2 to reach my library handler?
>>
>> Does OMPI use SIGUSR1/2 for other purposes?
>>
>> Is there some other clever way I can kick my library at runtime to dump its debug code? Like maybe interface with the MPI debug code somehow so things like padb could trigger this debug logic?
>>
>> Thanks in advance,
>>
>> Steve.
>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>