Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] Unable to build OMPI 1.4.2 and newer w/Intel 10 or Intel 11 compilers
From: David Gunter (dog_at_[hidden])
Date: 2010-08-20 16:20:40


I configure using --prefix and --with-platform=/contrib/platform/lanl/tlcc/debug-panasas

This works for every compiler except Intel. The "make" phase terminates with

libtool: link: /opt/Intel/cce/10.0.023/bin/icpc -I/opt/panfs/include -shared-intel -g -finline-functions -fexceptions -pthread -fexceptions -o .libs/ompi_info components.o ompi_info.o output.o param.o version.o ../../../ompi/.libs/libmpi.so -lrdmacm -libverbs /usr/projects/hpctools/dog/openmpi-build/openmpi-1.4.2/orte/.libs/libopen-rte.so /usr/projects/hpctools/dog/openmpi-build/openmpi-1.4.2/opal/.libs/libopen-pal.so -lnuma -ldl -lnsl -lutil -pthread -Wl,-rpath,/usr/projects/packages/openmpi/tlcc/openmpi-1.4.2-intel-debug/lib
../../../ompi/.libs/libmpi.so: undefined reference to `__invalid_size_argument_for_IOC'
make[2]: *** [ompi_info] Error 1
make[2]: Leaving directory `/usr/projects/hpctools/dog/openmpi-build/openmpi-1.4.2/ompi/tools/ompi_info'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/projects/hpctools/dog/openmpi-build/openmpi-1.4.2/ompi'
make: *** [all-recursive] Error 1

The actual problem is in the system include files, namely /usr/include/asm-generic/ioctl.h and is well described here:

https://bugzilla.redhat.com/show_bug.cgi?id=473947

The "ugly" fix recommended in the write-up works for the simple reproducer code given but has anyone figured out how to apply such a fix to the OMPI code?

Thanks,
david

--
David Gunter
HPC-3: Infrastructure Team
Los Alamos National Laboratory