Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [Open MPI] #2538: PGI compiler issues
From: Larry Baker (baker_at_[hidden])
Date: 2010-08-20 13:02:23


Jeff,

I have not yet finished finding all the problems I'm seeing in
1.5rc5. All I have done so far is look for the ones that I fixed for
OpenMPI 1.4.2. For example, compiling with PGI 10.3 on Linux fails.
(Has anyone else tried PGI 10.x?) The Intel compiler issues messages
I haven't tracked down on Mac OS X, and I haven't even tried PathScale
or Intel on Linux yet.

Larry Baker
US Geological Survey
650-329-5608
baker_at_[hidden]

On Aug 20, 2010, at 8:23 AM, Open MPI wrote:

> #2538: PGI compiler issues
> ---------------------
> +------------------------------------------------------
> Reporter: jsquyres | Owner:
> Type: defect | Status: new
> Priority: major | Milestone: Open MPI 1.5.1
> Version: trunk | Keywords:
> ---------------------
> +------------------------------------------------------
> Larry Baker posted a bunch of PGI compiler issues:
>
> * http://www.open-mpi.org/community/lists/devel/2010/08/8297.php
> * http://www.open-mpi.org/community/lists/devel/2010/08/8298.php
> * http://www.open-mpi.org/community/lists/devel/2010/08/8299.php
> * http://www.open-mpi.org/community/lists/devel/2010/08/8300.php
> * http://www.open-mpi.org/community/lists/devel/2010/08/8301.php
>
> Some of them are Libtool issues, but some of them are OMPI issues.
> None
> appear to be drastic correctness issues (nor are they regressions), so
> they shouldn't hold up 1.5.0. But we should fix them nonetheless (and
> submit upstream to Libtool where appropriate).
>
> --
> Ticket URL: <https://svn.open-mpi.org/trac/ompi/ticket/2538>
> Open MPI <http://www.open-mpi.org/>
>