Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] [PATCH] openmpi: get it built with newer autoconf
From: Sebastian Andrzej Siewior (openmpi_at_[hidden])
Date: 2010-08-18 10:59:32


From: Sebastian Andrzej Siewior <bigeasy_at_[hidden]>

Reported as Debian bug #592892. AS_VAR_GET missbehaves in newer
autoconf. Since it is deprecated switch to AS_VAR_COPY which gets things
done right. Both are cursed.

Signed-off-by: Sebastian Andrzej Siewior <bigeasy_at_[hidden]>

---
 config/f77_get_alignment.m4 |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/config/f77_get_alignment.m4 b/config/f77_get_alignment.m4
index aa3d318..ba1fb96 100644
--- a/config/f77_get_alignment.m4
+++ b/config/f77_get_alignment.m4
@@ -90,7 +90,7 @@ EOF
                  AC_MSG_ERROR([Could not determine alignment of $1])])])
         rm -rf conftest*])
 
-    $2=AS_VAR_GET([type_var])
+    AS_VAR_COPY([$2], [type_var])
     AS_VAR_POPDEF([type_var])dnl
     OMPI_VAR_SCOPE_POP
 ])
-- 
1.5.6.5