Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] v1.5 .so version numbers
From: George Bosilca (bosilca_at_[hidden])
Date: 2010-06-07 22:29:16


Totally insane ... but I was not talking about your rationale. ^^

How did we ended up with the following situation:

-libmca_common_sm_so_version=1:0:0
-libmca_common_mx_so_version=0:0:0
+libmca_common_sm_so_version=2:0:0
+libmca_common_mx_so_version=1:0:0

Where the same type of component (common sm and mx here) have different version numbers?

  Thanks,
    george.

On Jun 5, 2010, at 06:08 , Ralf Wildenhues wrote:

> Hi Jeff,
>
> * Jeff Squyres wrote on Thu, Jun 03, 2010 at 09:34:16PM CEST:
>> SHORT VERSION: We broke ABI from the 1.4 series to the v1.5 series. I
>> propose changing all the libtool .so version numbers as shown below to
>> enforce that break. Can someone sanity check this?
>
> Looks sane to me, with the details you have given.
>
> Cheers,
> Ralf
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel