Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] The" Missing Symbol" issue and OpenMPI on NetBSD
From: Kevin.Buckley_at_[hidden]
Date: 2010-05-11 20:33:36


> Which libltdl version is that NetBSD ltdl.h from? Which version is
> in opal/libltdl? Have you tried not doing the above change?
>
> libltdl 2.2.x has incompatible changes over 1.5.x, both in the library
> as well as in the header, as well as (I think) in preloaded modules.

Hey Ralf,

The libtool distinfo file implies NetBSD currently uses libtool-2.2.6b.

An ldd of mpirun shows -lltdl.7 => /usr/pkg/lib/libltdl.so.7

I do need to attempt a build of 1.4.2 here in ECS, so I'll try
building without the patches but I seem to recall that if those
libtool-related patches

opal/Makefile.in
configure
opal/mca/base/mca_base_component_find.c
opal/mca/base/mca_base_component_repository.c
test/support/components.h
test/support/components.c

were not applied, it did not even build. But we'll see.

And if you are reading this, Alexsej, have you,as the real
"OpenMPI on NetBSD" man, built a 1.4.2 as yet ?

Kevin

-- 
Kevin M. Buckley                                  Room:  CO327
School of Engineering and                         Phone: +64 4 463 5971
 Computer Science
Victoria University of Wellington
New Zealand