Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] compile openmpi error on debian
From: Matthias Jurenz (matthias.jurenz_at_[hidden])
Date: 2010-04-06 04:33:56


Hi Yaohui,

can you tell me the version of your gcc and g++ compiler?
It seems to me that your g++ compiler is older (<4.2) than your gcc compiler.
If that's true, then we have to enhance the VT configure, so that the
availability of '-fopenmp' for g++ will be tested.

Matthias

On Monday 05 April 2010 03:33:06 hu yaohui wrote:
> Thank you very much!
>
> Yaohui!
>
> On Sat, Apr 3, 2010 at 7:09 PM, Jeff Squyres <jsquyres_at_[hidden]> wrote:
> > Can you try Open MPI v1.4.1?
> >
> > If that doesn't work, you can disable building VampirTrace; it's an
> > optional component of Open MPI with the following configure argument:
> >
> > ./configure --enable-contrib-no-build=vt ...
> >
> > On Apr 3, 2010, at 1:22 AM, hu yaohui wrote:
> > > Hi all,
> > > when i make openmpi on debian, i meet the following error that i dont
> >
> > know why?
> >
> > > <snip>
> > > Making all in vtfilter
> > > make[6]: Entering directory
> >
> > `/root/openmpi-1.4-ht/ompi/contrib/vt/vt/tools/vtfilter'
> >
> > > g++ -DHAVE_CONFIG_H -I. -I../.. -I../../extlib/otf/otflib
> >
> > -I../../extlib/otf/otflib -I../../vtlib/ -I../../vtlib -D_GNU_SOURCE
> > -fopenmp -DVT_OMP -g -finline-functions -pthread -MT vtfilter-vt_filter.o
> > -MD -MP -MF .deps/vtfilter-vt_filter.Tpo -c -o vtfilter-vt_filter.o `test
> > -f 'vt_filter.cc' || echo './'`vt_filter.cc
> >
> > > cc1plus: error: unrecognized command line option "-fopenmp"
> > > make[6]: *** [vtfilter-vt_filter.o] Error 1
> > > make[6]: Leaving directory
> >
> > `/root/openmpi-1.4-ht/ompi/contrib/vt/vt/tools/vtfilter'
> >
> > > make[5]: *** [all-recursive] Error 1
> > > make[5]: Leaving directory
> >
> > `/root/openmpi-1.4-ht/ompi/contrib/vt/vt/tools'
> >
> > > make[4]: *** [all-recursive] Error 1
> > > make[4]: Leaving directory `/root/openmpi-1.4-ht/ompi/contrib/vt/vt'
> > > make[3]: *** [all] Error 2
> > > make[3]: Leaving directory `/root/openmpi-1.4-ht/ompi/contrib/vt/vt'
> > > make[2]: *** [all-recursive] Error 1
> > > make[2]: Leaving directory `/root/openmpi-1.4-ht/ompi/contrib/vt'
> > > make[1]: *** [all-recursive] Error 1
> > > make[1]: Leaving directory `/root/openmpi-1.4-ht/ompi'
> > > make: *** [all-recursive] Error 1
> > > </snip>
> > > someone tell me it's the gcc version's problem,but my gcc is the latest
> >
> > one,
> >
> > > is someone know the reason i meet this probelm
> > >
> > > Thanks & Regards
> > > Yaohui Hu
> > > _______________________________________________
> > > devel mailing list
> > > devel_at_[hidden]
> > > http://www.open-mpi.org/mailman/listinfo.cgi/devel
> >
> > --
> > Jeff Squyres
> > jsquyres_at_[hidden]
> > For corporate legal information go to:
> > http://www.cisco.com/web/about/doing_business/legal/cri/
> >
> >
> > _______________________________________________
> > devel mailing list
> > devel_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/devel
>