Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] need help when make
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-03-23 16:03:40


You probably want to add "-avoid-version" to the mca_btl_ht_LDFLAGS (and the others).

See the Libtool docs for more info here; but in general, we don't use the .so versioning scheme for OMPI plugins. Only for actual shared libraries that apps link against.

On Mar 23, 2010, at 9:32 AM, hu yaohui wrote:

> Hi George,Jeff and All
> Recently i add a component into the btl,named HT,it is very similar to sm.i meet a problem when make.
> steps to reproduce
> 1:make three ht directories under
> ~/ompi/mca/btl/ht ~/ompi/mca/mpool/ht ~/ompi/mca/common/ht,
> 2:i copy most code and file from sm component
> 3:i run ./autogen.sh no problem
> 4:run make i get the follow error
> <snip>
> make[2]: Entering directory `/home/loki/openmpi-1.4-ht/ompi/mca/common/ht'
> /bin/sh ../../../../libtool --tag=CC --mode=link gcc -g -finline-functions -fno-strict-aliasing -pthread -fvisibility=hidden -version-info -export-dynamic -o libmca_common_ht.la -rpath /usr/local/ompiht/lib common_ht_mmap.lo -lnsl -lutil -lm
> libtool: link: CURRENT `-export-dynamic' must be a nonnegative integer
> libtool: link: `-export-dynamic' is not valid version information
> </snip>
> can you tell me why?my libtool is the latest version 2.2.6b.
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/