Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] how to add a component in the ompi?
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-03-15 11:41:26


On Mar 15, 2010, at 8:18 AM, hu yaohui wrote:

> i did what you told me before to add a new component,now i could see my added component through ./configure --help.but when i run make ,i met some problems i couldn't understand.
> <snip>
> libtool: Version mismatch error. This is libtool 2.2.4, but the
> libtool: definition of this LT_INIT comes from libtool 2.2.6b.
> libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
> libtool: and run autoconf again.
> </snip>
> i just dont know how to recreate aclocal.m4.Could you give a explanation or some other materials about it on line?

This *usually* means that autogen.sh didn't run completely properly. Did you install all the GNU Autotools in the way described in the top-level HACKING file? (e.g., install them all to the same $prefix)

If you can't find the error, send all the data listed on the http://www.open-mpi.org/community/help/ (please compress!).

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/