Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Build issue: mpi_portable_platform.h
From: Joshua Hursey (jjhursey_at_[hidden])
Date: 2010-03-12 18:06:16


I think I figured it out. The error was coming from a Mercurial branch cloned from my internal HG+SVN branch. HG previously marked "mpi_portable_platform.h" as a file to not include in rev. control since it was auto-generated. Now that it is not auto-generated, it needs to be included in the rev. control.

The fix (in case anyone hits the same problem) is to remove "mpi_portable_platform.h" from the .hgignore in your HG+SVN, then 'hg addremove', 'hg commit'. Then things are better.

Thanks for the pointers to the rev #, that helped.

Cheers,
Josh

On Mar 12, 2010, at 4:42 PM, Rainer Keller wrote:

> Hi Josh,
> this is caused by moving mpi_portable_platform.h.in file in two steps from
> ompi/include to opal/include -- in order to be used by opal_info and
> orte_info.
>
> You need to autogen.sh again after svn up to at least r22789.
>
> Hope, this helps?
>
> Best regards,
> RAiner
>
>
> On Friday 12 March 2010 04:17:41 pm Joshua Hursey wrote:
>> I noticed the following build error on the OMPI trunk (r22821) on IU's Odin
>> machine: make[3]: *** No rule to make target `mpi_portable_platform.h',
>> needed by `all-am'. Stop.
>>
>> I took a quick pass through the svn commit log and did not see anything
>> that would have broken this. Any thoughts on what could be causing this?
>>
>> -- Josh
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>
> --
> ------------------------------------------------------------------------
> Rainer Keller, PhD Tel: +1 (865) 241-6293
> Oak Ridge National Lab Fax: +1 (865) 241-4811
> PO Box 2008 MS 6164 Email: keller_at_[hidden]
> Oak Ridge, TN 37831-2008 AIM/Skype: rusraink