Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] RFC: ABI break between 1.4 and 1.5 / .so versioning
From: Ralf Wildenhues (Ralf.Wildenhues_at_[hidden])
Date: 2010-02-17 15:05:42


Hello Jeff,

* Jeff Squyres wrote on Wed, Feb 17, 2010 at 08:19:25PM CET:
> The issue is that if the user has to specify -static to their linker,
> they *also* have to specify --ompi:static, or Bad Things will happen.
> Or, if they don't specify -static but *only* specify --ompi:static,
> Bad Things will happen. In short: it seems like adding yet another
> wrapper-compiler-specific flag to the MPI ecosystem will cause
> confusion, fear, and possibly the death of some cats.

Do you care for omitting -lopen-pal and -lorte only for capable Linux
systems? With new-enough binutils, you should be able to use
-Wl,--as-needed -Wl,--no-as-needed around these two libs.

I'm not entirely sure I understand your argumentation for why libmpi
from 1.5.x has to be binary incompatible, but I haven't fully thought
through this yet.

Cheers,
Ralf