Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [patch] Verifying the message queue DLL build
From: Terry Dontje (Terry.Dontje_at_[hidden])
Date: 2009-12-08 09:36:29


Ashley Pittman wrote:
> On Tue, 2009-12-08 at 07:39 -0500, Terry Dontje wrote:
>
>> Ashley Pittman wrote:
>>
>>> I've seen several cases now where people have functional, installed MPI
>>> libraries yet when they've come to use padb they have discovered a build
>>> problem with the Message Queue DLL which prevents it from working.
>>>
>>>
>>>
>> The cases I've seen this happen is with the Sun Studio compiler when a
>> source file pulls in a header that defines an inline static function
>> that uses some extern symbols but the inline static function itself is
>> never used. For some reason Sun Studio (I believe I've seen another
>> compiler do this also pgi or pathscale I think) decides to make those
>> extern symbols unresolved instead of just ignoring them.
>>
>
> That explains a couple of occurrences I've seen. Another example is
> Jeffs debug-handles branch where the code incorrectly called free
> instead of mqs_free, unfortunately free is #defined to be opal_free
> which then becomes an undefined symbol.
>
>
>> The current trunk and 1.5 branch should have this issue extricated from
>> it. However, this seems to always creep in every so often. So the
>> below test is greatly appreciated. Also, have you ran this test against
>> the trunk and 1.5, yet (is my belief of things are clean there correct)?
>>
>
> I've run it against a slightly stale version of the trunk which is as
> you say clean currently. I'm not sure where I'd get a 1.5 branch from
> but if you point me to it I can test this as well.
>
You can get it from the svn branch repo:
https://svn.open-mpi.org/svn/ompi/branches/v1.5
You might as well also try 1.4 which should also be clean:
https://svn.open-mpi.org/svn/ompi/branches/v1.4

--td
> Ashley,
>
>