Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] 1.3.4 blocker
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-11-03 20:33:20


Avneesh/QLogic just pointed out to me that we have a binary
compatibility issue (he's going to file a blocker ticket shortly).
When we changed the .so version numbers right before 1.3.4rc3, we made
it that apps compiled with 1.3.3 will not run against 1.3.4 because
the apps are dependent upon libopen-rte and libopen-pal. This is
likely because the wrapper compilers explicitly -lopen-rte and -lopen-
pal, rather than letting them get pulled in implicitly (I *think*
that's why -- but it's late and I haven't tried it).

Simple test: mpicc hello.c -o hello against a 1.3.3 install. Then
change your LD_LIBRARY_PATH to point to a 1.3.4rc3 install (assumedly
in a different tree). Run ldd on hello; it'll show libopen-rte.so and
libopen-pal.so as not found.

It's too late to fix this for the 1.3/1.4 series; perhaps we can fix
it in the 1.5 series properly. But I think we might have to lie about
the .so version numbers for 1.3.4 to make the binary compatibility work.

George / Brad -- we should chat on the phone tomorrow to figure this
out (when I have more brain power to think about this properly). :-(

-- 
Jeff Squyres
jsquyres_at_[hidden]