Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Memory corruption with mpool
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-11-03 11:00:02


On Nov 3, 2009, at 10:02 AM, Mondrian Nuessle wrote:

> hm, I did not set any threading related options in configure, so I
> guess threading was not disabled.
>
> I compiled it again with the following configure options,
>
> --enable-debug --enable-memchecker --enable-mem-debug --disable-ft-
> thread --disable-progress-threads --disable-mpi-threads
>
> and the behavior did change, although it still does not work
> completely. I will investigate further.
>

FWIW: if you're building from a tarball, the various "debug" options
are not the default (it defaults to an optimized build). All the
thread stuff is disabled by default, however. So your specifying them
should not change anything (it's not harmful to specify disabling
them; it should just be exactly the same as not specifying them).

-- 
Jeff Squyres
jsquyres_at_[hidden]