Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Trunk is brokem ?
From: Ralph Castain (rhc_at_[hidden])
Date: 2009-10-21 14:42:15


Thanks - impossible to know what explicit includes are required for
every environment. We have been building the trunk without problem on
our systems.

Appreciate the fix!

On Oct 21, 2009, at 10:30 AM, Pavel Shamis (Pasha) wrote:

> It was broken :-(
> I fixed it - r22119
>
> Pasha
>
> Pavel Shamis (Pasha) wrote:
>> On my systems I see follow error:
>>
>> gcc -DHAVE_CONFIG_H -I. -I../../../../opal/include -I../../../../
>> orte/include -I../../../../ompi/include -I../../../../opal/mca/
>> paffinity/linux/plpa/src/libplpa -I../../../.. -O3 -DNDEBUG -Wall -
>> Wundef -Wno-long-long -Wsign-compare -Wmissing-prototypes -Wstrict-
>> prototypes -Wcomment -pedantic -Werror-implicit-function-
>> declaration -finline-functions -fno-strict-aliasing -pthread -
>> fvisibility=hidden -MT sensor_pru.lo -MD -MP -MF .deps/
>> sensor_pru.Tpo -c sensor_pru.c -fPIC -DPIC -o .libs/sensor_pru.o
>> sensor_pru_component.c: In function 'orte_sensor_pru_open':
>> sensor_pru_component.c:77: error: implicit declaration of function
>> 'opal_output'
>>
>> Looks like the sensor code is broken.
>>
>> Thanks,
>> Pasha
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel