Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] ompi_info requesting CPUs?
From: Terry Dontje (Terry.Dontje_at_[hidden])
Date: 2009-10-20 05:53:06


Not that I want to delay 1.3.4 anymore than it has been but this seems
like a possible blocker. Can this be CMR'd for 1.3.4 or is this truly a
1.4 CMR?

--td

Ralph Castain wrote:
> Fixed in r22111
>
> Thanks
>
> On Oct 19, 2009, at 8:13 PM, Eugene Loh wrote:
>
>> Somewhere between r22090 and r22109, ompi_info started (erroneously)
>> requesting CPUs.
>>
>> E.g., r22090 is good:
>>
>> % ompi_info | grep Open MPI:
>> Open MPI: 1.7a1r22090
>>
>> But r22109 is bad:
>>
>> % ompi_info | grep Open MPI:
>> --------------------------------------------------------------------------
>>
>> Your job has requested more cpus per process(rank) than there
>> are cpus in a socket:
>>
>> Cpus/rank: 1
>> #cpus/socket: 0
>>
>> Please correct one or both of these values and try again.
>> --------------------------------------------------------------------------
>>
>> A component framework failed to open properly.
>> ompi_info will likely not display all configuration information
>> Open MPI: 1.7a1r22109
>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel