Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] ompi-trunk: have MPI_REAL2 (if available) but missing MPI_COMPLEX4
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-09-26 10:00:31


On Sep 23, 2009, at 3:33 PM, Lisandro Dalcin wrote:

> Disclaimer: I have almost no experience with Fortran, nor I'm needing
> this, but anyway (perhaps just as a reminder for you) :-)...

Lucky for you! ;-)

> 1) Open MPI exposes MPI_LOGICAL{1|2|4|8}, and they are not (AFAIK)
> listed in the MPI standard (I cannot found them in MPI-2.2)

Mmm. Good point. Looks like we were over-zealous there.

> 2) The MPI-2.2 standard DO list MPI COMPLEX4 (at least in 2.2) ...

I filed https://svn.open-mpi.org/trac/ompi/ticket/2032 to cover both
of these issues.

Thanks!

-- 
Jeff Squyres
jsquyres_at_[hidden]