Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Failed datatype test
From: Ralph Castain (rhc_at_[hidden])
Date: 2009-09-04 09:37:36


Correcting my own statement here: it was bombing on the IU machines
that generate the nightly tarball, hence the error reports. I removed
it because our automated systems were unable to generate nightly
tarballs until it was removed.

It also bombed on my Mac when I tried to test it manually.

Sorry for mis-speak.

On Sep 4, 2009, at 7:32 AM, Ralph Castain wrote:

> Before or after I removed the test? If you look at the MTT reports,
> you'll find that opal_datatype_test bombed on almost every system
> with an assert failure.
>
> On Sep 3, 2009, at 9:53 PM, Jeff Squyres wrote:
>
>> FWIW, I get a bunch of valid-looking compiler warnings when running
>> "make check" in the test/datatype directory.
>>
>> On Sep 3, 2009, at 7:42 PM, Ralph Castain wrote:
>>
>>> Hi folks
>>>
>>> A recent commit to the trunk is apparently causing "make check" to
>>> fail due to an assertion failure in an opal datatype test. I have
>>> turned this test "off" until someone can fix it as it is preventing
>>> the creation of a tarball.
>>>
>>> Could someone knowledgeable in the datatype changes over the last
>>> few
>>> weeks/months please fix this?
>>>
>>> Thanks
>>> Ralph
>>>
>>> _______________________________________________
>>> devel mailing list
>>> devel_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>>
>>
>>
>> --
>> Jeff Squyres
>> jsquyres_at_[hidden]
>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>