Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI devel] -display-map behavior in 1.3
From: Greg Watson (g.watson_at_[hidden])
Date: 2009-05-04 11:29:14


Ralph,

I did find another issue in 1.3 though. It looks like with the -xml
option you're sending output tagged with <stderr> to stderr, whereas
it would probably be better if everything was sent to stdout.
Otherwise it's necessary to parse the stderr stream separately.

Greg

On May 1, 2009, at 10:47 AM, Greg Watson wrote:

> Arrgh! Sorry, my bad. I must have been linked against an old version
> or something. When I recompiled the output went away.
>
> Greg
>
> On May 1, 2009, at 10:09 AM, Ralph Castain wrote:
>
>> Interesting - I'm not seeing this behavior:
>>
>> graywolf54:trunk rhc$ mpirun -n 3 --xml --display-map hostname
>> <map>
>> <host name="graywolf54.lanl.gov" slots="1" max_slots="0">
>> <process rank="0"/>
>> <process rank="1"/>
>> <process rank="2"/>
>> </host>
>> </map>
>> <stdout rank="0">graywolf54.lanl.gov</stdout>
>> <stdout rank="1">graywolf54.lanl.gov</stdout>
>> <stdout rank="2">graywolf54.lanl.gov</stdout>
>> graywolf54:trunk rhc$
>>
>> Can you tell me more about when you see this? Note that the display-
>> map output should always appear on stderr because that is our
>> default output device.
>>
>>
>> On Fri, May 1, 2009 at 7:39 AM, Ralph Castain <rhc_at_[hidden]>
>> wrote:
>> Hmmm...no, that's a bug. I'll fix it.
>>
>> Thanks!
>>
>>
>>
>> On Fri, May 1, 2009 at 7:24 AM, Greg Watson <g.watson_at_[hidden]>
>> wrote:
>> Ralf,
>>
>> I've just noticed that if I use '-xml -display-map', I get the xml
>> version of the map and then the non-xml version is sent to stderr
>> (wrapped in xml tags). Was this by design? In my view it would be
>> better to suppress the non-xml map altogether if the -xml option.
>> 1.4 seems to do the same.
>>
>> Greg
>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel