Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [Open MPI] #1881: Remove -lopenmpi-malloc support
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-04-14 16:28:42


Does anyone have any objections to this ticket for the v1.5 series?

On Apr 14, 2009, at 4:21 PM, Open MPI wrote:

> #1881: Remove -lopenmpi-malloc support
> ------------------------
> +---------------------------------------------------
> Reporter: jsquyres | Owner: jsquyres
> Type: enhancement | Status: new
> Priority: major | Milestone: Open MPI 1.5
> Version: trunk | Keywords:
> ------------------------
> +---------------------------------------------------
> -lopenmpi-malloc was introduced in v1.3 and was deprecated in
> v1.3.2 when
> we stopped using mallopt. The libopenmpi-malloc library still
> exists for
> the rest of the 1.3 and 1.4 series, but is empty / harmless.
>
> In v1.5, we should remove this library.
>
> --
> Ticket URL: <https://svn.open-mpi.org/trac/ompi/ticket/1881>
> Open MPI <http://www.open-mpi.org/>
>
>

-- 
Jeff Squyres
Cisco Systems