Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] require newer autoconf?
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-03-17 21:00:33


Per this thread:

     http://www.open-mpi.org/community/lists/users/2009/03/8402.php

It took a *loooong* time to figure out that an outdated Autoconf
install was the culprit of the "restrict" mess. The issue is that
somewhere between v2.61 and v2.63, Autoconf changed the order of
looking for "restrict"-like keywords -- AC 2.63 has the "good" order;
AC 2.61 has the "bad" order (hence, PGI worked for me with AC 2.63,
but barfed for Mostyn with AC 2.61).

Should we have our autogen.sh force the use of AC 2.63 and above?
(currently, it forces 2.59 and above)

-- 
Jeff Squyres
Cisco Systems