Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI devel] VT compile error: Fwd: [ofa-general] OFED 1.4.1 (rc1) is available
From: Matthias Jurenz (matthias.jurenz_at_[hidden])
Date: 2009-03-09 03:59:05


Unfortunately, I have no write access to the OFED bugzilla, so I answer
to the OMPI devel list...

It sounds like the following issue that we had early January:

http://www.open-mpi.org/community/lists/devel/2009/01/5102.php

The bottom line was that we don't know what's wrong.
However, there are these workarounds to solve this problem:

- setting 'use_default_rpm_opt_flags' to 0
- adding configure option '--with-contrib-vt-flags=--disable-iotrace'

Matthias

On Thu, 2009-03-05 at 16:43 +0200, Pavel Shamis (Pasha) wrote:
> Adding pointer to OFED bugzilla ticket for more information:
> https://bugs.openfabrics.org/show_bug.cgi?id=1537
>
> Jeff Squyres wrote:
> > VT guys --
> >
> > It looks like we still have a compile bug in OMPI 1.3.1rc4... See below.
> >
> > Do you think you can get a fix ASAP for OMPI 1.3.1final?
> >
> >
> > Begin forwarded message:
> >
> >> *From: *"PN" <poknam_at_[hidden] <mailto:poknam_at_[hidden]>>
> >> *Date: *March 5, 2009 12:51:28 AM EST
> >> *To: *"Tziporet Koren" <tziporet_at_[hidden]
> >> <mailto:tziporet_at_[hidden]>>
> >> *Cc: *<ewg_at_[hidden] <mailto:ewg_at_[hidden]>>,
> >> <general_at_[hidden] <mailto:general_at_[hidden]>>
> >> *Subject:** Re: [ofa-general] OFED 1.4.1 is available*
> >>
> >> HI,
> >>
> >> I have a build error of OFED-1.4.1-rc1 under CentOS 5.2:
> >>
> >> .....
> >> Build openmpi_gcc RPM
> >> Running rpmbuild --rebuild --define '_topdir /var/tmp/OFED_topdir'
> >> --define 'dist %{nil}' --target x86_64 --define '_name openmpi_gcc'
> >> --define 'mpi_selector /usr/bin/mpi-selector' --define
> >> 'use_mpi_selector 1' --define 'install_shell_scripts 1' --define
> >> 'shell_scripts_basename mpivars' --define '_usr /usr' --define 'ofed
> >> 0' --define '_prefix /usr/mpi/gcc/openmpi-1.3.1rc4' --define
> >> '_defaultdocdir /usr/mpi/gcc/openmpi-1.3.1rc4' --define '_mandir
> >> %{_prefix}/share/man' --define 'mflags -j 4' --define
> >> 'configure_options --with-openib=/usr
> >> --with-openib-libdir=/usr/lib64 CC=gcc CXX=g++ F77=gfortran
> >> FC=gfortran --enable-mpirun-prefix-by-default' --define
> >> 'use_default_rpm_opt_flags 1'
> >> /opt/software/packages/ofed/OFED-1.4.1-rc1/OFED-1.4.1-rc1/SRPMS/openmpi-1.3.1rc4-1.src.rpm
> >> Failed to build openmpi RPM
> >> See /tmp/OFED.28377.logs/openmpi.rpmbuild.log
> >>
> >>
> >> In /tmp/OFED.28377.logs/openmpi.rpmbuild.log:
> >> .....
> >> gcc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib
> >> -I../extlib/otf/otflib -I../extlib/otf/otflib -D_GNU_SOURCE
> >> -DBINDIR=\"/usr/mpi/gcc/openmpi-1.3.1rc4/bin\"
> >> -DDATADIR=\"/usr/mpi/gcc/openmpi-1.3.1rc4/share\" -DRFG -DVT_MEMHOOK
> >> -DVT_IOWRAP -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
> >> -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -MT
> >> vt_iowrap_helper.o -MD -MP -MF .deps/vt_iowrap_helper.Tpo -c -o
> >> vt_iowrap_helper.o vt_iowrap_helper.c
> >> mv -f .deps/vt_memhook.Tpo .deps/vt_memhook.Po
> >> gcc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib
> >> -I../extlib/otf/otflib -I../extlib/otf/otflib -D_GNU_SOURCE
> >> -DBINDIR=\"/usr/mpi/gcc/openmpi-1.3.1rc4/bin\"
> >> -DDATADIR=\"/usr/mpi/gcc/openmpi-1.3.1rc4/share\" -DRFG -DVT_MEMHOOK
> >> -DVT_IOWRAP -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
> >> -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -MT
> >> rfg_regions.o -MD -MP -MF .deps/rfg_regions.Tpo -c -o rfg_regions.o
> >> rfg_regions.c
> >> vt_iowrap.c:1242: error: expected declaration specifiers or '...'
> >> before numeric constant
> >> vt_iowrap.c:1243: error: conflicting types for '__fprintf_chk'
> >> mv -f .deps/vt_iowrap_helper.Tpo .deps/vt_iowrap_helper.Po
> >> make[5]: *** [vt_iowrap.o] Error 1
> >> make[5]: *** Waiting for unfinished jobs....
> >> mv -f .deps/vt_comp_gnu.Tpo .deps/vt_comp_gnu.Po
> >> mv -f .deps/rfg_regions.Tpo .deps/rfg_regions.Po
> >> make[5]: Leaving directory
> >> `/var/tmp/OFED_topdir/BUILD/openmpi-1.3.1rc4/ompi/contrib/vt/vt/vtlib'
> >> make[4]: *** [all-recursive] Error 1
> >> make[4]: Leaving directory
> >> `/var/tmp/OFED_topdir/BUILD/openmpi-1.3.1rc4/ompi/contrib/vt/vt'
> >> make[3]: *** [all] Error 2
> >> make[3]: Leaving directory
> >> `/var/tmp/OFED_topdir/BUILD/openmpi-1.3.1rc4/ompi/contrib/vt/vt'
> >> make[2]: *** [all-recursive] Error 1
> >> make[2]: Leaving directory
> >> `/var/tmp/OFED_topdir/BUILD/openmpi-1.3.1rc4/ompi/contrib/vt'
> >> make[1]: *** [all-recursive] Error 1
> >> make[1]: Leaving directory
> >> `/var/tmp/OFED_topdir/BUILD/openmpi-1.3.1rc4/ompi'
> >> make: *** [all-recursive] Error 1
> >> error: Bad exit status from /var/tmp/rpm-tmp.40739 (%build)
> >>
> >>
> >> RPM build errors:
> >> user jsquyres does not exist - using root
> >> group eng10 does not exist - using root
> >> user jsquyres does not exist - using root
> >> group eng10 does not exist - using root
> >> Bad exit status from /var/tmp/rpm-tmp.40739 (%build)
> >>
> >>
> >> The error seems similar to
> >> http://www.open-mpi.org/community/lists/devel/2009/01/5230.php
> >>
> >> Regards,
> >> PN
> >>
> >>
> >> 2009/3/5 Tziporet Koren <tziporet_at_[hidden]
> >> <mailto:tziporet_at_[hidden]>>
> >>
> >> Hi,
> >>
> >> OFED-1.4.1-rc1 release is available on
> >>
> >> _http://www.openfabrics.org/downloads/OFED/ofed-1.4.1/OFED-1.4.1-rc1.tgz_
> >>
> >>
> >> To get BUILD_ID run ofed_info
> >>
> >> Please report any issues in bugzilla
> >> _https://bugs.openfabrics.org/_ for OFED 1.4.1
> >>
> >> Vladimir & Tziporet
> >>
> >> ========================================================================
> >>
> >>
> >> Release information:
> >>
> >> ------------------------------
> >>
> >> Linux Operating Systems:
> >>
> >> - RedHat EL4 up4: 2.6.9-42.ELsmp *
> >>
> >> - RedHat EL4 up5: 2.6.9-55.ELsmp
> >>
> >> - RedHat EL4 up6: 2.6.9-67.ELsmp
> >>
> >> - RedHat EL4 up7: 2.6.9-78.ELsmp
> >>
> >> - RedHat EL5: 2.6.18-8.el5
> >>
> >> - RedHat EL5 up1: 2.6.18-53.el5
> >>
> >> - RedHat EL5 up2: 2.6.18-92.el5
> >>
> >> - RedHat EL5 up3: 2.6.18-128.el5
> >>
> >> - OEL 4.5: 2.6.9-55.ELsmp
> >>
> >> - OEL 5.2: 2.6.18-92.el5
> >>
> >> - CentOS 5.2: 2.6.18-92.el5
> >>
> >> - Fedora C9: 2.6.25-14.fc9 *
> >>
> >> - SLES10: 2.6.16.21-0.8-smp
> >>
> >> - SLES10 SP1: 2.6.16.46-0.12-smp
> >>
> >> - SLES10 SP1 up1: 2.6.16.53-0.16-smp
> >>
> >> - SLES10 SP2: 2.6.16.60-0.21-smp
> >>
> >> - SLES11 RC3: 2.6.27.13-1-default
> >>
> >> - OpenSuSE 10.3: 2.6.22.5-31 *
> >>
> >> - kernel.org <http://kernel.org>: 2.6.26 and
> >> 2.6.27
> >>
> >> * Minimal QA for these versions
> >>
> >> Systems:
> >>
> >> * x86_64
> >>
> >> * x86
> >>
> >> * ia64
> >>
> >> * ppc64
> >>
> >>
> >> Main Changes from OFED-1.4
> >>
> >> ======================
> >>
> >> - Added support for RHEL 5.3 and SLES11 RC3
> >>
> >> - Added RHEL 5.2 backports for NFS/RDMA
> >>
> >> - Updated MPI packages:
> >>
> >> mvapich-1.1.0-3143
> >>
> >> Open MPI 1.3.1-rc4
> >>
> >> - Updated bonding package: ib-bonding-0.9.0-38
> >>
> >> - Updated opensm version to include critical bug fixes
> >>
> >> - Fixed RDS iWARP support
> >>
> >> - Low level drivers updated: ehca, mlx4, cxgb3, nes
> >>
> >> - Bug fixes
> >>
> >> - Attached kernel git tree changes for details
> >>
> >> <<ofa_kernel-1.4_1.4.1-rc1.log>>
> >>
> >> Tasks that should be completed for RC2:
> >>
> >> =============================
> >>
> >> 1. High priority bug fixes
> >>
> >> 2. RHEL 5.2 32 bits compilation issue (due to NFS/RDMA backports)
> >>
> >> 3. Open MPI 1.3.1 release
> >>
> >> 4. MVAPICH 1.1.1.minor release with critical bug fixes
> >>
> >> 5. OSM release 3.2.6
> >>
> >> 6. Documentation update
> >>
> >>
> >> _______________________________________________
> >> general mailing list
> >> general_at_[hidden] <mailto:general_at_[hidden]>
> >> http://lists.openfabrics.org/cgi-bin/mailman/listinfo/general
> >>
> >> To unsubscribe, please visit
> >> http://openib.org/mailman/listinfo/openib-general
> >>
> >>
> >> _______________________________________________
> >> general mailing list
> >> general_at_[hidden] <mailto:general_at_[hidden]>
> >> http://lists.openfabrics.org/cgi-bin/mailman/listinfo/general
> >>
> >> To unsubscribe, please visit
> >> http://openib.org/mailman/listinfo/openib-general
> >
> >
> > --
> > Jeff Squyres
> > Cisco Systems
> >
> > ------------------------------------------------------------------------
> >
> > _______________________________________________
> > devel mailing list
> > devel_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>



  • application/x-pkcs7-signature attachment: smime.p7s