Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] PML Start error?
From: George Bosilca (bosilca_at_[hidden])
Date: 2009-03-02 16:49:57


Right, this should be reinitialized at the beginning of each loop.
However, the current code works fine, it only call the
ompi_convertor_set_position twice if the condition is true. This
function check if the current position match the requested one, and
does nothing if its the case.

   george.

On Feb 28, 2009, at 09:26 , Jeff Squyres wrote:

> Looks that way to me, too.
>
> On Feb 27, 2009, at 5:34 PM, Eugene Loh wrote:
>
>> I'm looking at pml_ob1_start.c. It loops over requests and starts
>> them. It makes some decision about whether an old request can be
>> reused or if a new one must be allocated/initialized. So, there is
>> a variable named reuse_old_request. It's initialized to "true",
>> but if a new request must be alloced/inited, then it's set to false.
>>
>> The thing is, this variable is initialized to true only once, at
>> entry to the function and outside the loop over requests. This
>> strikes me as wrong. It appears that if ever the variable is set
>> to false, it will remain so until the end of the function. I would
>> think the intent is for the variable to be reset to true at the
>> start of every iteration.
>>
>> Yes/no?
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel