Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] OpenMPI rpm build 1.3rc3r20226 build failed
From: Matthias Jurenz (matthias.jurenz_at_[hidden])
Date: 2009-01-14 14:30:56


Sorry, I have searched the whole day for a solution of that problem, but
unfortunately, I'm clueless :-( I cannot say which flag causes the
compile error. Furthermore, I'm also unable to reproduce this error on
some different platforms.
The coding style in the concerned source file looks also not special...

My suggestion is to use the workaround (configure flag) for the 1.3
release.

On Wed, 2009-01-14 at 07:57 -0500, Jeff Squyres wrote:
> Is there some code that can be fixed instead? I.e., is this feature
> totally incompatible with whatever RPM compiler flags are used, or is
> it just some coding style that these particular flags don't like?
>
>
> On Jan 14, 2009, at 5:05 AM, Matthias Jurenz wrote:
>
> > Another workaround should be to disable the I/O tracing feature of VT
> > by adding the configure option
> >
> > '--with-contrib-vt-flags=--disable-iotrace'
> >
> > That will have the effect that the upcoming OMPI-rpm's have no support
> > for I/O tracing, but in our opinion it is not so bad...
> >
> > Furthermore, we could add the configure option in
> > 'ompi/contrib/vt/configure.m4' to retain the feature-consistency
> > between
> > the rpm's and the source packages.
> >
> >
> > Matthias
> >
> > On Tue, 2009-01-13 at 17:13 +0200, Lenny Verkhovsky wrote:
> >> I don't want to move changes ( default value of the flag), since
> >> there
> >> are important people, for whom it works :)
> >> I also think that this is VT issue, but I guess we are the only one
> >> who experience the errors.
> >>
> >> we can now overwrite this params from the environment as a
> >> workaround,
> >> Mike comitted buildrpm.sh script to the trunk r20253 that allows
> >> overwriting params from the environment.
> >>
> >> we observed the problem on CentOS 5.2 with boundled gcc and RedHat
> >> 5.2
> >> with boundled gcc.
> >>
> >> #uname -a
> >> Linux elfit1 2.6.18-92.el5 #1 SMP Tue Jun 10 18:51:06 EDT 2008 x86_64
> >> x86_64 x86_64 GNU/Linux
> >>
> >> #lsb_release -a
> >> LSB Version:
> >> :core-3.1-amd64:core-3.1-ia32:core-3.1-noarch:graphics-3.1-
> >> amd64:graphics-3.1-ia32:graphics-3.1-noarch
> >> Distributor ID: CentOS
> >> Description: CentOS release 5.2 (Final)
> >> Release: 5.2
> >> Codename: Final
> >>
> >> gcc version 4.1.2 20071124 (Red Hat 4.1.2-42)
> >>
> >> Best regards,
> >> Lenny.
> >>
> >>
> >> On Tue, Jan 13, 2009 at 4:40 PM, Jeff Squyres <jsquyres_at_[hidden]>
> >> wrote:
> >>> I'm still guessing that this is a distro / compiler issue -- I can
> >>> build
> >>> with the default flags just fine...?
> >>>
> >>> Can you specify what distro / compiler you were using?
> >>>
> >>> Also, if you want to move the changes that have been made to
> >>> buildrpm.sh to
> >>> the v1.3 branch, just file a CMR. That file is not included in
> >>> release
> >>> tarballs, so Tim can move it over at any time.
> >>>
> >>>
> >>>
> >>> On Jan 13, 2009, at 6:35 AM, Lenny Verkhovsky wrote:
> >>>
> >>>> it seems that setting use_default_rpm_opt_flags to 0 solves the
> >>>> problem.
> >>>> Maybe vt developers should take a look on it.
> >>>>
> >>>> Lenny.
> >>>>
> >>>>
> >>>> On Sun, Jan 11, 2009 at 2:40 PM, Jeff Squyres
> >>>> <jsquyres_at_[hidden]> wrote:
> >>>>>
> >>>>> This sounds like a distro/compiler version issue.
> >>>>>
> >>>>> Can you narrow down the issue at all?
> >>>>>
> >>>>>
> >>>>> On Jan 11, 2009, at 3:23 AM, Lenny Verkhovsky wrote:
> >>>>>
> >>>>>> it doesnt happen if I do autogen, configure and make install,
> >>>>>> only when I try to make an rpm from the tar file.
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>> On Thu, Jan 8, 2009 at 9:43 PM, Jeff Squyres
> >>>>>> <jsquyres_at_[hidden]> wrote:
> >>>>>>>
> >>>>>>> This doesn't happen in a normal build of the same tree?
> >>>>>>>
> >>>>>>> I ask because both 1.3r20226 builds fine for me manually (i.e.,
> >>>>>>> ./configure;make and buildrpm.sh).
> >>>>>>>
> >>>>>>>
> >>>>>>> On Jan 8, 2009, at 8:15 AM, Lenny Verkhovsky wrote:
> >>>>>>>
> >>>>>>>> Hi,
> >>>>>>>>
> >>>>>>>> I am trying to build rpm from nightly snaposhots of 1.3
> >>>>>>>>
> >>>>>>>> with the downloaded buildrpm.sh and ompi.spec file from
> >>>>>>>> http://svn.open-mpi.org/svn/ompi/branches/v1.3/contrib/dist/linux/
> >>>>>>>>
> >>>>>>>> I am getting this error
> >>>>>>>> .....................
> >>>>>>>> Making all in vtlib
> >>>>>>>> make[5]: Entering directory
> >>>>>>>>
> >>>>>>>> `/hpc/home/USERS/lennyb/work/svn/release/scripts/dist-1.3--1/
> >>>>>>>> OMPI/BUILD/
> >>>>>>>> openmpi-1.3rc3r20226/ompi/contrib/vt/vt/vtlib'
> >>>>>>>> gcc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib
> >>>>>>>> -I../extlib/otf/otflib -I../extlib/otf/otflib -D_GNU_SOURCE
> >>>>>>>> -DBINDIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/bin\"
> >>>>>>>> -DDATADIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/share\" -DRFG
> >>>>>>>> -DVT_MEMHOOK -DVT_IOWRAP -O2 -g -pipe -Wall -Wp,-
> >>>>>>>> D_FORTIFY_SOURCE=2
> >>>>>>>> -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64
> >>>>>>>> -mtune=generic -MT vt_comp_gnu.o -MD -MP -MF .deps/
> >>>>>>>> vt_comp_gnu.Tpo -c
> >>>>>>>> -o
> >>>>>>>> vt_comp_gnu.o vt_comp_gnu.c
> >>>>>>>> gcc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib
> >>>>>>>> -I../extlib/otf/otflib -I../extlib/otf/otflib -D_GNU_SOURCE
> >>>>>>>> -DBINDIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/bin\"
> >>>>>>>> -DDATADIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/share\" -DRFG
> >>>>>>>> -DVT_MEMHOOK -DVT_IOWRAP -O2 -g -pipe -Wall -Wp,-
> >>>>>>>> D_FORTIFY_SOURCE=2
> >>>>>>>> -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64
> >>>>>>>> -mtune=generic -MT vt_memhook.o -MD -MP -MF .deps/
> >>>>>>>> vt_memhook.Tpo -c -o
> >>>>>>>> vt_memhook.o vt_memhook.c
> >>>>>>>> gcc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib
> >>>>>>>> -I../extlib/otf/otflib -I../extlib/otf/otflib -D_GNU_SOURCE
> >>>>>>>> -DBINDIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/bin\"
> >>>>>>>> -DDATADIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/share\" -DRFG
> >>>>>>>> -DVT_MEMHOOK -DVT_IOWRAP -O2 -g -pipe -Wall -Wp,-
> >>>>>>>> D_FORTIFY_SOURCE=2
> >>>>>>>> -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64
> >>>>>>>> -mtune=generic -MT vt_memreg.o -MD -MP -MF .deps/
> >>>>>>>> vt_memreg.Tpo -c -o
> >>>>>>>> vt_memreg.o vt_memreg.c
> >>>>>>>> gcc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib
> >>>>>>>> -I../extlib/otf/otflib -I../extlib/otf/otflib -D_GNU_SOURCE
> >>>>>>>> -DBINDIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/bin\"
> >>>>>>>> -DDATADIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/share\" -DRFG
> >>>>>>>> -DVT_MEMHOOK -DVT_IOWRAP -O2 -g -pipe -Wall -Wp,-
> >>>>>>>> D_FORTIFY_SOURCE=2
> >>>>>>>> -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64
> >>>>>>>> -mtune=generic -MT vt_iowrap.o -MD -MP -MF .deps/
> >>>>>>>> vt_iowrap.Tpo -c -o
> >>>>>>>> vt_iowrap.o vt_iowrap.c
> >>>>>>>> mv -f .deps/vt_memreg.Tpo .deps/vt_memreg.Po
> >>>>>>>> gcc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib
> >>>>>>>> -I../extlib/otf/otflib -I../extlib/otf/otflib -D_GNU_SOURCE
> >>>>>>>> -DBINDIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/bin\"
> >>>>>>>> -DDATADIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/share\" -DRFG
> >>>>>>>> -DVT_MEMHOOK -DVT_IOWRAP -O2 -g -pipe -Wall -Wp,-
> >>>>>>>> D_FORTIFY_SOURCE=2
> >>>>>>>> -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64
> >>>>>>>> -mtune=generic -MT vt_iowrap_helper.o -MD -MP -MF
> >>>>>>>> .deps/vt_iowrap_helper.Tpo -c -o vt_iowrap_helper.o
> >>>>>>>> vt_iowrap_helper.c
> >>>>>>>> mv -f .deps/vt_memhook.Tpo .deps/vt_memhook.Po
> >>>>>>>> gcc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib
> >>>>>>>> -I../extlib/otf/otflib -I../extlib/otf/otflib -D_GNU_SOURCE
> >>>>>>>> -DBINDIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/bin\"
> >>>>>>>> -DDATADIR=\"/opt/openmpi/1.3rc3r20226-V00/gcc/share\" -DRFG
> >>>>>>>> -DVT_MEMHOOK -DVT_IOWRAP -O2 -g -pipe -Wall -Wp,-
> >>>>>>>> D_FORTIFY_SOURCE=2
> >>>>>>>> -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64
> >>>>>>>> -mtune=generic -MT rfg_regions.o -MD -MP -MF .deps/
> >>>>>>>> rfg_regions.Tpo -c
> >>>>>>>> -o
> >>>>>>>> rfg_regions.o rfg_regions.c
> >>>>>>>> vt_iowrap.c:1242: error: expected declaration specifiers or
> >>>>>>>> '...'
> >>>>>>>> before
> >>>>>>>> numeric constant
> >>>>>>>> vt_iowrap.c:1243: error: conflicting types for '__fprintf_chk'
> >>>>>>>> mv -f .deps/vt_comp_gnu.Tpo .deps/vt_comp_gnu.Po
> >>>>>>>> make[5]: *** [vt_iowrap.o] Error 1
> >>>>>>>> make[5]: *** Waiting for unfinished jobs....
> >>>>>>>> mv -f .deps/vt_iowrap_helper.Tpo .deps/vt_iowrap_helper.Po
> >>>>>>>> mv -f .deps/rfg_regions.Tpo .deps/rfg_regions.Po
> >>>>>>>> make[5]: Leaving directory
> >>>>>>>>
> >>>>>>>> `/hpc/home/USERS/lennyb/work/svn/release/scripts/dist-1.3--1/
> >>>>>>>> OMPI/BUILD/
> >>>>>>>> openmpi-1.3rc3r20226/ompi/contrib/vt/vt/vtlib'
> >>>>>>>> make[4]: *** [all-recursive] Error 1
> >>>>>>>> make[4]: Leaving directory
> >>>>>>>>
> >>>>>>>> `/hpc/home/USERS/lennyb/work/svn/release/scripts/dist-1.3--1/
> >>>>>>>> OMPI/BUILD/
> >>>>>>>> openmpi-1.3rc3r20226/ompi/contrib/vt/vt'
> >>>>>>>> make[3]: *** [all] Error 2
> >>>>>>>> make[3]: Leaving directory
> >>>>>>>>
> >>>>>>>> `/hpc/home/USERS/lennyb/work/svn/release/scripts/dist-1.3--1/
> >>>>>>>> OMPI/BUILD/
> >>>>>>>> openmpi-1.3rc3r20226/ompi/contrib/vt/vt'
> >>>>>>>> make[2]: *** [all-recursive] Error 1
> >>>>>>>> make[2]: Leaving directory
> >>>>>>>>
> >>>>>>>> `/hpc/home/USERS/lennyb/work/svn/release/scripts/dist-1.3--1/
> >>>>>>>> OMPI/BUILD/
> >>>>>>>> openmpi-1.3rc3r20226/ompi/contrib/vt'
> >>>>>>>> make[1]: *** [all-recursive] Error 1
> >>>>>>>> make[1]: Leaving directory
> >>>>>>>>
> >>>>>>>> `/hpc/home/USERS/lennyb/work/svn/release/scripts/dist-1.3--1/
> >>>>>>>> OMPI/BUILD/
> >>>>>>>> openmpi-1.3rc3r20226/ompi'
> >>>>>>>> make: *** [all-recursive] Error 1
> >>>>>>>> error: Bad exit status from /var/tmp/rpm-tmp.32080 (%build)
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> RPM build errors:
> >>>>>>>> Bad exit status from /var/tmp/rpm-tmp.32080 (%build)
> >>>>>>>>
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> RPM build errors:
> >>>>>>>> Bad exit status from /var/tmp/rpm-tmp.32080 (%build)
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> full error.log attached
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> thanks,
> >>>>>>>> Lenny.
> >>>>>>>> <ompi.ompi_build.31401.log><mime-attachment.txt>
> >>>>>>>
> >>>>>>>
> >>>>>>> --
> >>>>>>> Jeff Squyres
> >>>>>>> Cisco Systems
> >>>>>>>
> >>>>>>> _______________________________________________
> >>>>>>> devel mailing list
> >>>>>>> devel_at_[hidden]
> >>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
> >>>>>>>
> >>>>>> _______________________________________________
> >>>>>> devel mailing list
> >>>>>> devel_at_[hidden]
> >>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
> >>>>>
> >>>>>
> >>>>> --
> >>>>> Jeff Squyres
> >>>>> Cisco Systems
> >>>>>
> >>>>> _______________________________________________
> >>>>> devel mailing list
> >>>>> devel_at_[hidden]
> >>>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
> >>>>>
> >>>> _______________________________________________
> >>>> devel mailing list
> >>>> devel_at_[hidden]
> >>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
> >>>
> >>>
> >>> --
> >>> Jeff Squyres
> >>> Cisco Systems
> >>>
> >>> _______________________________________________
> >>> devel mailing list
> >>> devel_at_[hidden]
> >>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
> >>>
> >> _______________________________________________
> >> devel mailing list
> >> devel_at_[hidden]
> >> http://www.open-mpi.org/mailman/listinfo.cgi/devel
> >>
> >
> > _______________________________________________
> > devel mailing list
> > devel_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>