Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] RFC: Add SunStudio/Libtool helper script for post-configure
From: Ralph Castain (rhc_at_[hidden])
Date: 2008-11-24 08:39:13


On Nov 23, 2008, at 1:19 AM, Ralf Wildenhues wrote:

> * Ethan Mallove wrote on Fri, Nov 21, 2008 at 09:01:56PM CET:
>> On Fri, Nov/21/2008 01:02:12PM, Ralf Wildenhues wrote:
>>> IMHO OpenMPI can use
>>> the solaris_use_stlport4=yes until such a functionality is in place.
>>
>> Nice. This workaround works. I don't suppose there's a similar
>> workaround to unset "wl" in the FC libtool section? If not, I think
>> we
>> still need the heinous post-configure workaround script. Otherwise,
>> since there won't be a stable Libtool that contains the Sun Fortran
>> fix for a while, I propose the attached patch.
>
> While I suppose your patch works, I think in similar situations,
> OpenMPI
> has resorted to patching input files to configure (like aclocal.m4 or
> ltmain.sh). Search autogen.sh for instances of 'patch'.

Interesting observation - I wonder if that would explain why I
recently started seeing an "aclocal.m4.rej" file every time I re-gen
the trunk?

Maybe one of those patches has an error in it?
Ralph

>
>
> (This is merely an observation; I am not an OpenMPI developer.)
>
> Cheers,
> Ralf
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel