Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] RFC: libopen-rte --> libompi-rte
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-11-06 12:38:33


WHAT: Rename libopen-rte to be libompi-rte (and probably other
supporting text)

WHY: ORTE is really quite specific to OMPI. We decided long ago that
ORTE would not split off from OMPI, and it has been specifically
tailored for OMPI. Indeed, Ralph has recently been expanding "ORTE"
to "OMPI Run Time Environment". So let's name the library what it
really is.

WHERE: See attached patch; basically, a bunch of Makefile.am's

WHEN: Before v1.3

TIMEOUT: Teleconference, Tues 11 Nov 2008

--------------

The change is fairly minor, and 98% of OMPI users won't notice. Only
those who are not using wrapper compilers properly will notice the
change (and they should be using the wrapper compilers; we strongly
recommended that everyone either directly use the wrapper compilers to
compile/link their apps, or use the wrappers to get the required flags
[including library names] to compile/link their apps).

I don't know if Sun has any policies about library name changes
between versions, or if it'll create problems since CT8 has already
been released. As a history note, we changed this library name in v1.2
from "liborte" to "libopen-rte". This would be another change.

-- 
Jeff Squyres
Cisco Systems