Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Upgrade GNU auto tools?
From: Ralf Wildenhues (Ralf.Wildenhues_at_[hidden])
Date: 2008-09-19 13:26:25


Hello OpenMPI developers,

on Darwin/OS X, recent Libtool has some debugging symbols issue fixed.
I think that was even raised on this list a short while ago. Also, an
issue with recent Intel compilers on Linux has been fixed.

Absoft support is not yet in Libtool, but Lahey is.

Hope that helps.

Cheers,
Ralf

* Jeff Squyres wrote on Fri, Sep 19, 2008 at 04:07:02PM CEST:
> Yep; there may be no real specific benefit, but it's good to get the
> most recent versions for a release branch before we freeze it.
>
> It *may* have fixed some Absoft compiler issues; I'm checking with
> Absoft on this (I didn't see anything specific about it in the release
> notes, and the data is not entirely clear because a few things changed
> in Absoft's MTT setup right around the same time).
>
> On Sep 19, 2008, at 10:04 AM, George Bosilca wrote:
>
>> I've been using these versions for some time, basically from the date
>> they get released. So far, no issues have been raised. However, I do
>> not see any benefit with these new versions (on Linux and Mac OS X).
>>
>> george.
>>
>> On Sep 19, 2008, at 9:56 AM, Tim Mattox wrote:
>>
>>> Just an FYI,
>>> Last night I switched the nightly tarball creation for the
>>> trunk and v1.3 to use the latest autoconf and libtool
>>> releases. AFAIK, everything worked fine.
>>> So, these are the versions of the various gnu tools
>>> we are currently using:
>>> m4-1.4.11
>>> autoconf-2.63
>>> automake-1.10.1
>>> libtool-2.2.6a
>>>
>>> You may want to upgrade your local installs of these for
>>> your own development work so we are all on the same version.
>>>
>>> On Thu, Sep 18, 2008 at 8:24 AM, Jeff Squyres <jsquyres_at_[hidden]>
>>> wrote:
>>>> Autoconf and Libtool released updates recently (to v2.63 and
>>>> v2.2.6a,
>>>> respectively). I have tested these versions with a local trunk
>>>> checkout and
>>>> they seem to work fine.
>>>>
>>>> Any objections to moving the nightly trunk and v1.3 tarballs to
>>>> these
>>>> versions?
>>>>
>>>> m4=m4-1.4.11
>>>> ac=autoconf-2.63
>>>> am=automake-1.10.1
>>>> lt=libtool-2.2.6a
>>>>
>>>> (we're still pre-1.3 lockdown, so I figured it was ok to move)