Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] IBCM error
From: Pavel Shamis (Pasha) (pasha_at_[hidden])
Date: 2008-07-14 09:21:24


>
> Should we not even build support for it?
I think IBCM CPC build should be enabled by default. The IBCM is
supplied with OFED so it should not be any problem during install.
>
> PRO: don't even allow the possibility of running with it, because we
> know that there are issues with the ibcm userspace library (i.e.,
> reduce problem reports from users)
>
> PRO: users don't have to have libibcm installed on compute nodes
> (we've actually gotten some complaints about this)
We got compliances only for case when ompi was build on platform with
IBCM and after it was run on platform without IBCM. Also we did not
have option to disable
the ibcm during compilation. So actually it was no way to install OMPI
on compute node. We added the option and the problem was resolved.
In most cases the OFED install is the same on all nodes and it should
not be any problem to build IBCM support by default.

Pasha