Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] IBCM error
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-07-14 08:28:23


On Jul 14, 2008, at 7:55 AM, Pavel Shamis (Pasha) wrote:

> I can add in head of query function something like :
>
> if (!mca_btl_openib_component.cpc_explicitly_defined)
> return OMPI_ERR_NOT_SUPPORTED;

That sounds reasonable until the ibcm userspace library issues can be
sorted out. Then perhaps this check can be removed.

Should we not even build support for it?

PRO: don't even allow the possibility of running with it, because we
know that there are issues with the ibcm userspace library (i.e.,
reduce problem reports from users)

PRO: users don't have to have libibcm installed on compute nodes
(we've actually gotten some complaints about this)

CON: OMPI is not release-synchronized with OFED; OFED could be
released with a fixed ibcm userspace library, but it still wouldn't be
built by default in OMPI

CON: users already have to have librdmacm installed on the compute
notes for the RDMA CM (e.g., probably mainly for iWARP support);
adding ibcm and rdmacm user libs at the same time might actually be
better (rather than rdmacm in v1.3 and ibcm in a future version)

Thoughts?

-- 
Jeff Squyres
Cisco Systems