Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Error after commit
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-07-03 14:48:15


I just did a commit and got the same error. I'll followup with the IU
admins; something probably didn't upgrade properly on the SVN side of
the post-commit-hooks or somesuch.

On Jul 3, 2008, at 10:58 AM, Ralph Castain wrote:

> Not sure if anyone else is seeing this, but I got a strange error
> output
> immediately following my last commit to the trunk:
>
> Warning: 'post-commit' hook failed with error output:
> Traceback (most recent call last):
> File "/opt/shnadm/rep/ompi/hooks/trac-post-commit-hook", line 200,
> in ?
> CommitHook()
> File "/opt/shnadm/rep/ompi/hooks/trac-post-commit-hook", line 145, in
> __init__
> self.env = open_environment(project)
> File "/opt/trac/lib/python2.3/site-packages/trac/env.py", line 463,
> in
> open_environment
> if env.needs_upgrade():
> File "/opt/trac/lib/python2.3/site-packages/trac/env.py", line 343,
> in
> needs_upgrade
> if participant.environment_needs_upgrade(db):
> File "/opt/trac/lib/python2.3/site-packages/trac/env.py", line 401,
> in
> environment_needs_upgrade
> raise TracError, 'Database newer than Trac version'
> trac.core.TracError: Database newer than Trac version
>
>
> Anyone have any insights? I know Trac was just updated - do we need
> to do
> something to our local checkouts and/or systems? Note this commit
> was done
> from milliways.osl.iu.edu, so perhaps there is some issue between the
> systems at IU?
>
> Ralph
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel

-- 
Jeff Squyres
Cisco Systems