Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] openib btl build question
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-05-21 16:43:49


On May 21, 2008, at 4:37 PM, Brian W. Barrett wrote:

>> ptmalloc2 is not *required* by the openib btl. But it is required on
>> Linux if you want to use the mpi_leave_pinned functionality. I see
>> one function call to __pthread_initialize in the ptmalloc2 code -- it
>> *looks* like it's a function of glibc, but I don't know for sure.
>
> There's actually more than that, it's just buried a bit. There's a
> whole
> bunch of thread-specific data stuff, which is wrapped so that
> different
> thread packages can be used (although OMPI only supports pthreads).
> The
> wrappers are in ptmalloc2/sysdeps/pthreads.

Doh! I didn't "grep -r"; my bad...

-- 
Jeff Squyres
Cisco Systems