Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] Intel ifort / Libtool 2.x problem
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-05-21 11:16:16


Heads up: Tim switched over the trunk tarballs yesterday to use
Libtool 2.2.4, Autoconf 2.62, and Automake 1.10.1.

MTT shows that there is a problem with ifort and LT 2.2.4 and Fortran
shared libraries on Linux -- LT seems to be dropping the necessary
compiler flags to build Fortran shared libraries. I did some more
testing and have filed a bug report with our friendly neighborhood
Libtool developers. I'll file an OMPI trac ticket when my message
arrives in the bug-libtool list web archives.

For the time being, if you want to build with the Intel compilers, you
must pass -fPIC in FCFLAGS:

     ./configure CC=icc CXX=icpc FC=ifort F77=ifort FCFLAGS=-fPIC ...

-- 
Jeff Squyres
Cisco Systems