Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI devel] Intel MPI Benchmark(IMB) using OpenMPI - Segmentation-fault error message.
From: Lenny Verkhovsky (lenny.verkhovsky_at_[hidden])
Date: 2008-04-30 09:02:16


On 4/30/08, Mukesh K Srivastava <srimks11_at_[hidden]> wrote:
>
> Hi.
>
> I am using IMB-3.1, an Intel MPI Benchmark tool with OpenMPI(v-1.2.5). In
> /IMB-3.1/src/make_mpich file, I had only given the decalartion for MPI_HOME,
> which takes care for CC, OPTFLAGS & CLINKER. Building IMB_MPI1, IMP-EXT &
> IMB-IO happens succesfully.
>
> I get proper results of IMB Benchmark with command "-np 1" as mpirun
> IMB-MPI1, but for "-np 2", I get below errors -
>
> -----
> [mukesh_at_n161 src]$ mpirun -np 2 IMB-MPI1
> [n161:13390] *** Process received signal ***
> [n161:13390] Signal: Segmentation fault (11)
> [n161:13390] Signal code: Address not mapped (1)
> [n161:13390] Failing at address: (nil)
> [n161:13390] [ 0] /lib64/tls/libpthread.so.0 [0x399e80c4f0]
> [n161:13390] [ 1] /home/mukesh/openmpi/prefix/lib/openmpi/mca_btl_sm.so
> [0x2a9830f8b4]
> [n161:13390] [ 2] /home/mukesh/openmpi/prefix/lib/openmpi/mca_btl_sm.so
> [0x2a983109e3]
> [n161:13390] [ 3]
> /home/mukesh/openmpi/prefix/lib/openmpi/mca_btl_sm.so(mca_btl_sm_component_progress+0xbc)
> [0x2a9830fc50]
> [n161:13390] [ 4]
> /home/mukesh/openmpi/prefix/lib/openmpi/mca_bml_r2.so(mca_bml_r2_progress+0x4b)
> [0x2a97fce447]
> [n161:13390] [ 5]
> /home/mukesh/openmpi/prefix/lib/libopen-pal.so.0(opal_progress+0xbc)
> [0x2a958fc343]
> [n161:13390] [ 6]
> /home/mukesh/openmpi/prefix/lib/openmpi/mca_oob_tcp.so(mca_oob_tcp_msg_wait+0x22)
> [0x2a962e9e22]
> [n161:13390] [ 7]
> /home/mukesh/openmpi/prefix/lib/openmpi/mca_oob_tcp.so(mca_oob_tcp_recv+0x677)
> [0x2a962f1aab]
> [n161:13390] [ 8]
> /home/mukesh/openmpi/prefix/lib/libopen-rte.so.0(mca_oob_recv_packed+0x46)
> [0x2a9579d243]
> [n161:13390] [ 9]
> /home/mukesh/openmpi/prefix/lib/openmpi/mca_gpr_proxy.so(orte_gpr_proxy_put+0x2f3)
> [0x2a96508c8f]
> [n161:13390] [10]
> /home/mukesh/openmpi/prefix/lib/libopen-rte.so.0(orte_smr_base_set_proc_state+0x425)
> [0x2a957c391d]
> [n161:13390] [11]
> /home/mukesh/openmpi/prefix/lib/libmpi.so.0(ompi_mpi_init+0xa1e)
> [0x2a9559f042]
> [n161:13390] [12]
> /home/mukesh/openmpi/prefix/lib/libmpi.so.0(PMPI_Init_thread+0xcb)
> [0x2a955e1c5b]
> [n161:13390] [13] IMB-MPI1(main+0x33) [0x403543]
> [n161:13390] [14] /lib64/tls/libc.so.6(__libc_start_main+0xdb)
> [0x399e11c3fb]
> [n161:13390] [15] IMB-MPI1 [0x40347a]
> [n161:13390] *** End of error message ***
> [n161:13391] *** Process received signal ***
> [n161:13391] Signal: Segmentation fault (11)
> [n161:13391] Signal code: Address not mapped (1)
> [n161:13391] Failing at address: (nil)
> [n161:13391] [ 0] /lib64/tls/libpthread.so.0 [0x399e80c4f0]
> [n161:13391] [ 1] /home/mukesh/openmpi/prefix/lib/openmpi/mca_btl_sm.so
> [0x2a9830f8b4]
> [n161:13391] [ 2] /home/mukesh/openmpi/prefix/lib/openmpi/mca_btl_sm.so
> [0x2a983109e3]
> [n161:13391] [ 3]
> /home/mukesh/openmpi/prefix/lib/openmpi/mca_btl_sm.so(mca_btl_sm_component_progress+0xbc)
> [0x2a9830fc50]
> [n161:13391] [ 4]
> /home/mukesh/openmpi/prefix/lib/openmpi/mca_bml_r2.so(mca_bml_r2_progress+0x4b)
> [0x2a97fce447]
> [n161:13391] [ 5]
> /home/mukesh/openmpi/prefix/lib/libopen-pal.so.0(opal_progress+0xbc)
> [0x2a958fc343]
> [n161:13391] [ 6]
> /home/mukesh/openmpi/prefix/lib/openmpi/mca_oob_tcp.so(mca_oob_tcp_msg_wait+0x22)
> [0x2a962e9e22]
> [n161:13391] [ 7]
> /home/mukesh/openmpi/prefix/lib/openmpi/mca_oob_tcp.so(mca_oob_tcp_recv+0x677)
> [0x2a962f1aab]
> [n161:13391] [ 8]
> /home/mukesh/openmpi/prefix/lib/libopen-rte.so.0(mca_oob_recv_packed+0x46)
> [0x2a9579d243]
> [n161:13391] [ 9] /home/mukesh/openmpi/prefix/lib/libopen-rte.so.0
> [0x2a9579e910]
> [n161:13391] [10]
> /home/mukesh/openmpi/prefix/lib/libopen-rte.so.0(mca_oob_xcast+0x140)
> [0x2a9579d824]
> [n161:13391] [11]
> /home/mukesh/openmpi/prefix/lib/libmpi.so.0(ompi_mpi_init+0xaf1)
> [0x2a9559f115]
> [n161:13391] [12]
> /home/mukesh/openmpi/prefix/lib/libmpi.so.0(PMPI_Init_thread+0xcb)
> [0x2a955e1c5b]
> [n161:13391] [13] IMB-MPI1(main+0x33) [0x403543]
> [n161:13391] [14] /lib64/tls/libc.so.6(__libc_start_main+0xdb)
> [0x399e11c3fb]
> [n161:13391] [15] IMB-MPI1 [0x40347a]
> [n161:13391] *** End of error message ***
>
> -----
>
> Query#1: Any clue for above?

It worked for me.

1. maybe mpirun belongs to another MPI.
2. try to define hosts ( -H host1,host2 )

Query#2: How can I include seperate exe file and have the IMB for it, e.g,
> writing a hello.c with MPI elementary API calls, compiling with mpicc and
> performing IMB for the same exe.?

you have all the sorces
maybe in IMB's README you can find something

Best Regards,
Lenny

BR
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>