Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Fix for XLC + libtool issue
From: Ralf Wildenhues (Ralf.Wildenhues_at_[hidden])
Date: 2008-04-25 07:40:28


Hi Jeff, all,

* Jeff Squyres wrote on Fri, Apr 25, 2008 at 12:35:12PM CEST:
> Good to hear that upgrading fixes this problem.
>
> We actually already have an outstanding ticket to upgrade to 2.2.2
> (https://svn.open-mpi.org/trac/ompi/ticket/1265 ). We were following
> the Libtool development process closely and
> waiting for at least 2.2.2 (get past 2.2.0).

2.2.2 is out since April 1st, and has seen a number of fixes since. We
hope to do 2.2.4 soon, but of course if you try it out before then any
eventual remaining issues may be fixed before that.

FWIW I've been building OMPI with development versions of autotools all
the time (but only tested on GNU/Linux/x86).

> Additionally, Ralf W. recomends to us that we should also upgrade
> Autoconf to 2.62 or later. I've been loosely watching that process;
> 2.62 requires a newer GNU m4 which we haven't yet decided if we want
> to require.

Yes you need GNU m4 1.4.5 or newer. m4 1.4.11 and Autoconf 2.62 speed
up auto* and config.status run time, respectively. For the latter, we
used OMPI as test bed application, see the first set of timings in:
<http://thread.gmane.org/gmane.comp.sysutils.autoconf.patches/3985>

Cheers,
Ralf