Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] Fix for XLC + libtool issue
From: Sérgio Durigan Júnior (sergiodj_at_[hidden])
Date: 2008-04-22 13:09:28


Hi everybody,

Taking a look at your website, I could see an issue about compiling Open
MPI shared libs using IBM's XLC compiler + libtool:

http://www.open-mpi.org/faq/?category=building#build-ibm-compilers

Well, I think we have the solution for this: upgrading libtool to the
latest version seems to work well in this case. So, I'd like to ask you
to upgrade the libtool used by Open MPI to the latest version (2.2.2 or
more), and change this FAQ to provide information about how the user can
manually update libtool in older versions of Open MPI.

The instructions for upgrading libtool manually are:

1) Get the latest libtool package from
http://www.gnu.org/software/libtool

2) Untar, compile and install it

3) Have a fresh and clean Open MPI source tree

4) Inside there, run 'libtoolize --force'

5) Then run 'aclocal'

6) At last, run 'autoreconf --force'

After that, you'll be able to build Open MPI without problems :-).

Thanks in advance,

-- 
Sérgio Durigan Júnior
Linux on Power Toolchain - Software Engineer
Linux Technology Center - LTC
IBM Brazil