Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] 3 test failures
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-03-06 17:01:48


Nope, you're not off-topic at all. This has been a debate among us
developers for a few days now... :-)

The issue is that these tests are now doing something that assume that
OMPI has been installed. We've sent an RFC around to the developers
proposing how to fix it (easy solution: just remove these tests from
"make check"), and have a longer-term fix filed as a trac ticket
(allow carto to fail gracefully when there are no components
available: https://svn.open-mpi.org/trac/ompi/ticket/1232).

On Mar 6, 2008, at 4:54 PM, Ralf Wildenhues wrote:

> Hello,
>
> I've just stumbled over three testsuite failures on GNU/Linux x86,
> with an out-of-tree build (mkdir build; cd build;
> ../ompi_trunk/configure -C). Hope I'm not completely off-topic
> here...
>
> Cheers,
> Ralf
>
> PASS: ompi_bitmap
> --------------------------------------------------------------------------
> Sorry! You were supposed to get help about:
> opal_init:startup:internal-failure
> from the file:
> help-opal-runtime.txt
> But I couldn't find any file matching that name. Sorry!
> --------------------------------------------------------------------------
> Failure : Comparison failure
> Expected result: 0
> Test result: -13
> SUPPORT: OMPI Test failed: opal_hash_table_t (1 of 1 failed)
> FAIL: opal_hash_table
> --------------------------------------------------------------------------
> Sorry! You were supposed to get help about:
> opal_init:startup:internal-failure
> from the file:
> help-opal-runtime.txt
> But I couldn't find any file matching that name. Sorry!
> --------------------------------------------------------------------------
> Failure : Comparison failure
> Expected result: 0
> Test result: -13
> SUPPORT: OMPI Test failed: (null) (1 of 1 failed)
> FAIL: opal_list
> --------------------------------------------------------------------------
> Sorry! You were supposed to get help about:
> opal_init:startup:internal-failure
> from the file:
> help-opal-runtime.txt
> But I couldn't find any file matching that name. Sorry!
> --------------------------------------------------------------------------
> Failure : Comparison failure
> Expected result: 0
> Test result: -13
> SUPPORT: OMPI Test failed: opal_value_array_t (1 of 1 failed)
> FAIL: opal_value_array
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel

-- 
Jeff Squyres
Cisco Systems