Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] vt configuration issues
From: Matthias Jurenz (matthias.jurenz_at_[hidden])
Date: 2008-03-03 11:27:49


Hello,

the 'make dist[clean]' problem should be fixed now. To avoid that Make
enters a 'ompi/contrib'-directory
of a disabled contributed software the Makefile variable
OMPI_CONTRIB_DIST_SUBDIRS must not be set.
I've tested this fix as follows:

1. configure --enable-contrib-no-build=vt
    make distclean
-> works
2. configure --enable-contrib-no-build=vt
    make dist # the tarball doesn't contain VT sources
(omp/contrib/vt/vt)
    tar xfz <tarball>
    configure ; make ; make install
-> works
3. test 1 in VPATH mode
4. test 2 in VPATH mode

Matthias

On Fr, 2008-02-29 at 13:10 +0100, Andreas Knüpfer wrote:

> On Thursday 28 February 2008, Jeff Squyres wrote:
> > I can't remember if I posted about this before or not -- should we
> > disable trunk/VT building by default while the configuration issues
> > are being worked out?
>
> Which config issues are you refering to? Is it about the 'make distclean' that
> fails if you explicitly disabled VT before?
>
> I see no easy fix for this, because you will get an incomplete set of
> Makefiles if you ask for an incomplete configure. Yet, by default everything
> should be fine.
>
> Therefore, I'd like to keep it enabled by default ... well, of course I
> would ;)
>
> Are there any other isses open with VT config?
>
> Andreas
>
>

--
Matthias Jurenz,
Center for Information Services and 
High Performance Computing (ZIH), TU Dresden, 
Willersbau A106, Zellescher Weg 12, 01062 Dresden
phone +49-351-463-31945, fax +49-351-463-37773




  • application/x-pkcs7-signature attachment: smime.p7s