Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] PLPA ready?
From: Sharon Melamed (sharonm135_at_[hidden])
Date: 2008-02-19 08:59:51


Jeff,

The new PLPA fails in compilation. there is a need to change the
paffinity API's:
1. max_processor_id with one parameter --> get_processor_info with 2 parameters.
2. max_socket with one parameter --> get_socket_info with 2 parameters.
3. max_core with 2 parameters --> get_core_info with 3 parameters.

I changed these API's internally in my copy of the trunk and tested
the new PLPA.
it works properly.

Do you have an idea how to integrate the new PLPA with the new API's ?

Sharon.

On Feb 19, 2008 4:31 AM, Jeff Squyres <jsquyres_at_[hidden]> wrote:
> Sharon/Lenny --
>
> Could you try out the newest PLPA RC for me? I think it's ready. I
> just posted rc4 to the web site (I posted that rc3 was available, and
> then found a small bug that necessitated rc4): http://www.open-mpi.org/software/plpa/v1.1/
>
> You should be able to do this to test it within an OMPI SVN checkout:
>
> cd opal/mca/paffinity/linux
> mv plpa bogus
> tar zxf plpa-1.1rc4.tar.gz
> ln -s plpa-1.1rc4 plpa
> cd ../../../..
> ./autogen && ./configure ...... && make -j 4 ......
>
> Let me know if it works for you properly (configure, build, and
> function). If so, I think it's ready for release. I'll then do the
> SVN magic to bring it to the OMPI trunk.
>
> Thanks.
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>