Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] vt integration -- still problems on os x
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-01-11 13:18:48


I am able to compile now on OS X -- great!

However, I seem to get some weird errors when running on Leopard:

[13:14] beezle:~/tmp/foo % mpicc-vt ../hello.c -o hello
[13:14] beezle:~/tmp/foo % nm hello > hello.nm
[13:14] beezle:~/tmp/foo % setenv VT_NMFILE ~/tmp/foo/hello.nm
[13:14] beezle:~/tmp/foo % mpirun -np 4 hello
Hello, world!
Hello, world!
Hello, world!
vtunify: Error: Could not open file ./a.1.uctl
Hello, world!

That's a weird one -- here's what the dir looks like:

[13:14] beezle:~/tmp/foo % ls -l
total 352
drwxrwxr-x 7 jsquyres staff 238 Jan 11 13:14 ./
drwxrwxr-x 41 jsquyres staff 1394 Jan 11 13:14 ../
-rw-rw-r-- 1 jsquyres staff 1601 Jan 11 13:14 a.0.def.z
-rw-rw-r-- 1 jsquyres staff 26 Jan 11 13:14 a.1.events.z
-rw-rw-r-- 1 jsquyres staff 4 Jan 11 13:14 a.otf
-rwxrwxr-x 1 jsquyres staff 150336 Jan 11 13:14 hello*
-rw-rw-r-- 1 jsquyres staff 13266 Jan 11 13:14 hello.nm

Just for the heckuvit, let's try running again...

[13:14] beezle:~/tmp/foo % mpirun -np 4 hello
Hello, world!
Hello, world!
Hello, world!
Hello, world!
Assertion failed: (p_vecLocDefs->size() > 0), function createGlobal,
file vt_unify_defs.cc, line 508.
vtunify: Error: Could not open file ./a.1.uctl
[13:14] beezle:~/tmp/foo %

Yoinks -- an assertion failure...

Successive runs seems to be variations on these errors (the assertion
failure and various "could not open" and "could not remove" errors).

On Jan 11, 2008, at 11:45 AM, Matthias Jurenz wrote:

> Hi Jeff,
>
> I could reproduce the linker problem with the sf.net GCC. Thanks for
> your hint.
> A header include was missing for STL's functional objects. :-(
>
>
> Matthias
>
>
> On Do, 2008-01-10 at 13:21 -0500, Jeff Squyres wrote:
>>
>> On Jan 10, 2008, at 10:19 AM, Andreas Knüpfer wrote:
>>
>> > unfortunately, we're unable to reproduce this error. Could you pass
>> > some more
>> > information about your configure command line? This was done with
>> > gcc 4.2 on
>> > mac os X, wasn't it?
>>
>> I'm on Leopard on my MBP with:
>>
>> ./configure --prefix=/Users/jsquyres/bogus --enable-mpi-f90 --
>> without-
>> threads
>>
>> But I might see the problem here -- I just realized/remembered that
>> I'm using the sf.net GCC install (hpc.sf.net). If I force /usr/bin/
>> gcc (and friends), it seems to work:
>>
>> ./configure --prefix=/Users/jsquyres/bogus CC=/usr/bin/gcc CXX=/usr/
>> bin/g++ --disable-mpi-fortran
>>
>> However, the hpc.sf.net OS X compilers are not uncommon (because they
>> provide fortran compiler support for OS X). Do you think you'll be
>> able to test with these compilers?
>>
> --
> Matthias Jurenz,
> Center for Information Services and
> High Performance Computing (ZIH), TU Dresden,
> Willersbau A106, Zellescher Weg 12, 01062 Dresden
> phone +49-351-463-31945, fax +49-351-463-37773
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel

-- 
Jeff Squyres
Cisco Systems