Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] SCTP noisy failure
From: Brad Penoff (penoff_at_[hidden])
Date: 2007-12-12 19:16:30


hey Jeff,

Does your system have sctp in the kernel as a module? This is the
default for most Linux systems so you may have to "modprobe sctp" to
get rid of the ESOCKTNOSUPPORT...

brad

On Dec 12, 2007 3:57 PM, Jeff Squyres <jsquyres_at_[hidden]> wrote:
> After the exclusivity change today, I notice that I am getting
> warnings for *every* mpirun from the SCTP BTL on RHEL4:
>
> [15:52] svbu-mpi:~/mpi % mpirun -np 2 hello
> [svbu-mpi.cisco.com][1,0][btl_sctp_component.c:
> 615:mca_btl_sctp_component_create_listen] socket() failed with errno=94
> [svbu-mpi.cisco.com][1,1][btl_sctp_component.c:
> 615:mca_btl_sctp_component_create_listen] socket() failed with errno=94
> Hello, world! I am 0 of 2 (svbu-mpi.cisco.com)
> Hello, world! I am 1 of 2 (svbu-mpi.cisco.com)
> [15:52] svbu-mpi:~/mpi %
>
> Can these be turned off? I have a default RHEL4 system -- I haven't
> done anything special to enable / disable SCTP. Is there a less noisy
> way to tell that SCTP is not enabled on a system?
>
> --
> Jeff Squyres
> Cisco Systems
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>