Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] SCTP noisy failure
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-12-12 18:57:59


After the exclusivity change today, I notice that I am getting
warnings for *every* mpirun from the SCTP BTL on RHEL4:

[15:52] svbu-mpi:~/mpi % mpirun -np 2 hello
[svbu-mpi.cisco.com][1,0][btl_sctp_component.c:
615:mca_btl_sctp_component_create_listen] socket() failed with errno=94
[svbu-mpi.cisco.com][1,1][btl_sctp_component.c:
615:mca_btl_sctp_component_create_listen] socket() failed with errno=94
Hello, world! I am 0 of 2 (svbu-mpi.cisco.com)
Hello, world! I am 1 of 2 (svbu-mpi.cisco.com)
[15:52] svbu-mpi:~/mpi %

Can these be turned off? I have a default RHEL4 system -- I haven't
done anything special to enable / disable SCTP. Is there a less noisy
way to tell that SCTP is not enabled on a system?

-- 
Jeff Squyres
Cisco Systems