Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] THREAD_MULTIPLE
From: Terry Dontje (Terry.Dontje_at_[hidden])
Date: 2007-11-28 13:20:44


Jeff Squyres wrote:
> The MPICH guys presented TCP results with THREAD_MULTIPLE at Euro PVM/
> MPI and frankly, I was amazed that it worked at all.
>
> I seriously doubt that we're going to advance the state of threading
> on the 1.2 series (which is nowhere as close as it is on the 1.3
> series).
>
>
And 1.3 I think still has a way to go to before one could really say it
supports THREAD_MULTIPLE.

--td
> On Nov 28, 2007, at 12:21 PM, Richard Graham wrote:
>
>
>> Are there not users that are using THREAD_MULTIPLE successfully, or
>> is this
>> on the trunk ? We know that the code is not where it needs to be,
>> but if
>> this takes away current functionality, I would prefer to display a
>> warning.
>>
>> Rich
>>
>>
>> On 11/28/07 11:27 AM, "Jeff Squyres" <jsquyres_at_[hidden]> wrote:
>>
>>
>>> We've had a few users complain about trying to use THREAD_MULTIPLE
>>> lately and having it not work.
>>>
>>> Here's a proposal: why don't we disable it (at least in the 1.2
>>> series)? Or, at the very least, put in a big stderr warning that is
>>> displayed when THREAD_MULTIPLE is selected?
>>>
>>> Comments?
>>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>
>
>