Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [OMPI svn-full] svn:open-mpi r16691
From: Adrian Knoth (adi_at_[hidden])
Date: 2007-11-08 15:20:19


On Thu, Nov 08, 2007 at 08:02:09AM -0500, Jeff Squyres wrote:

> >> All ROMIO patches *must* be coordinated with the ROMIO maintainers.
> > Upstream? That's the upstream patch.
> That was extracted from ROMIO itself? Which release?

>From Jiri:

The patch was extracted from a ROMIO sources that come with MPICH2 1.0.6.

As noted on the ROMIO web page (http://www-unix.mcs.anl.gov/romio/):

"Note: The version of ROMIO described on this page is an old one. We
haven't released newer versions of ROMIO as independent packages for a
while; they were included as part of MPICH2 and MPICH-1. You can get the
latest version of ROMIO when you download MPICH2 or MPICH-1."

--- end of Jiri ---

> > Jiri Polach has extracted the fix for this problem. Updating OMPI to a
> > newer ROMIO version should do the trick, so we might want to revert
> > r16693 and r16691.
> It would be great to upgrade to a newer version of ROMIO. Do you have
> the cycles to do it?

Let's see ;) If life is going to be boring, I'll have a look at it ;)

> If this is slated for v1.3, then I think it would be much better to
> back out that patch and then do a real upgrade.

ACK.

-- 
Cluster and Metacomputing Working Group
Friedrich-Schiller-Universität Jena, Germany
private: http://adi.thur.de