Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Bogdan Costescu (Bogdan.Costescu_at_[hidden])
Date: 2007-10-22 14:49:48


<short version>
Is there some known incompatibility of the latest stable versions with
the PathScale 3.0 compilers ?
</short version>

<long version>
I have a very puzzling problem with the following combination:
- PathScale 3.0 suite
- Open MPI 1.2.3 and 1.2.4 (both behave the same)
- Debian etch, kernel 2.6.22.9/x86_64 running on AMD Opteron

Upon invoking any installed binary (opmi_info, mpif90 --showinfo), I
get a segmentation fault. The trace looks strange (to me, at least ;-)):

Program terminated with signal 11, Segmentation fault.
#0 0x00000000004430d9 in _int_free (av=0x5b1ea0, mem=0x5b40b0) at /home/thor1/costescu/build/openmpi-1.2.4/opal/mca/memory/ptmalloc2/malloc.c:4416
4416 fwd->bk = p;
(gdb) bt
#0 0x00000000004430d9 in _int_free (av=0x5b1ea0, mem=0x5b40b0) at /home/thor1/costescu/build/openmpi-1.2.4/opal/mca/memory/ptmalloc2/malloc.c:4416
#1 0x000000000044141b in free (mem=0x5b40b0) at /home/thor1/costescu/build/openmpi-1.2.4/opal/mca/memory/ptmalloc2/malloc.c:3513
#2 0x00002b27dc920590 in vasprintf () from /lib/libc.so.6
#3 0x00002b27dc906588 in asprintf () from /lib/libc.so.6
#4 0x0000000000421274 in opal_output_init () at /home/thor1/costescu/build/openmpi-1.2.4/opal/util/output.c:130
#5 0x0000000000421c83 in do_open (output_id=-1, lds=0x591530) at /home/thor1/costescu/build/openmpi-1.2.4/opal/util/output.c:422
#6 0x0000000000421529 in opal_output_open (lds=0x591530) at /home/thor1/costescu/build/openmpi-1.2.4/opal/util/output.c:176
#7 0x00000000004201e4 in opal_malloc_init () at /home/thor1/costescu/build/openmpi-1.2.4/opal/util/malloc.c:67
#8 0x000000000040e6ac in opal_init_util () at runtime/opal_init.c:137
#9 0x000000000040932e in main (argc=2, argv=0x7fffceb02608) at /home/thor1/costescu/build/openmpi-1.2.4/opal/tools/wrappers/opal_wrapper.c:424

This happens only with the PathScale 3.0 compilers; I have no problems
when using the default gcc and friends version 4.1.2 compilers; I also
have no problems in using the PathScale 3.0 compilers either alone or
with Myricom's MPICH/MX.

The problem build was obtained after:

./configure --prefix=/home/thor1/costescu/openmpi-1.2.4-ps30 --enable-static --disable-shared --with-mx=/opt_local/mx --disable-io-romio --enable-debug --enable-pretty-print-stacktrace

(configure and make logs available on request)

I thought about asking here first to avoid any 'this is known' or
embarassing errors that I might have made, before filling a bug
report. The existing bugs related to PathScale compilers don't seem
to describe the symptoms that I'm seeing, unless it's some kind of
threading issue which seems to have no resolution yet...

Thanks in advance !
</long version>

--
Bogdan Costescu
IWR - Interdisziplinaeres Zentrum fuer Wissenschaftliches Rechnen
Universitaet Heidelberg, INF 368, D-69120 Heidelberg, GERMANY
Telephone: +49 6221 54 8869, Telefax: +49 6221 54 8868
E-mail: Bogdan.Costescu_at_[hidden]