Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Ralf Wildenhues (Ralf.Wildenhues_at_[hidden])
Date: 2007-08-27 17:12:14


Hello,

* Jeff Squyres wrote on Mon, Aug 27, 2007 at 04:07:22PM CEST:
> On Aug 27, 2007, at 9:23 AM, Ralph H Castain wrote:
> >
> > Making all in mca/timer/darwin
> > make[2]: Nothing to be done for `all'.
> > Making all in .
> > make[2]: *** No rule to make target `../opal/libltdl/libltdlc.la',
> > needed by
> > `libopen-pal.la'. Stop.

> Yes, if you're using --disable-dlopen, then libltdlc should not be
> linked in (because it [rightfully] won't exist).

FWIW, I can reproduce the error, I don't yet know who's at fault
(but if it turns out to be Libtool, I'd appreciate a report), but
I noted this unrelated nit in the configury. I guess you could
try setting LIBLTDL to '' in the case where you don't want to
build it.

Cheers,
Ralf

Index: configure.ac
===================================================================
--- configure.ac (revision 15970)
+++ configure.ac (working copy)
@@ -1052,7 +1052,7 @@
         AC_EGREP_HEADER([lt_dladvise_init], [opal/libltdl/ltdl.h],
                         [OPAL_HAVE_LTDL_ADVISE=1],
                         [OPAL_HAVE_LTDL_ADVISE=0])
- CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS_save"
 
         # Arrgh. This is gross. But I can't think of any other way to do
         # it. :-(