Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-08-27 10:07:22


Yes, if you're using --disable-dlopen, then libltdlc should not be
linked in (because it [rightfully] won't exist).

I can reproduce the problem on my MBP.

Brian -- did something change here recently?

On Aug 27, 2007, at 9:23 AM, Ralph H Castain wrote:

> Yo folks
>
> Just checked out a fresh copy of the trunk and tried to build it
> using my
> usual configure:
>
> ./configure --prefix=/Users/rhc/openmpi --with-devel-headers
> --disable-shared --enable-static --disable-mpi-f77 --disable-mpi-f90
> --enable-mem-debug --without-memory-manager --enable-debug
> --disable-progress-threads --disable-mpi-threads --disable-io-romio
> --without-threads --disable-dlopen
>
>
> Got this error:
>
> Making all in mca/timer/darwin
> make[2]: Nothing to be done for `all'.
> Making all in .
> make[2]: *** No rule to make target `../opal/libltdl/libltdlc.la',
> needed by
> `libopen-pal.la'. Stop.
> make[1]: *** [all-recursive] Error 1
> make: *** [all-recursive] Error 1
>
>
> It looks like some change may have broken one of these options?
>
> Ralph
>
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel

-- 
Jeff Squyres
Cisco Systems