Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Manuel Prinz (debian_at_[hidden])
Date: 2007-08-18 11:03:34


Hi everyone,

in the Debian package of OpenMPI there has been a patch [1] for some
time which I think is obsolete. I did some reading on that topic but I'm
not very familiar with assembler, so I'm asking you here.

As far as I can see, removing the patch doesn't change the binaries
much. Neither scanelf nor readelf show something I'd consider as
suspicious. I think that the .note.GNU-stack instruction is added to the
assembler files by generate-asm.pl, so everything's set properly.

But as I said, I'm not very familiar with the matter and it would be
great to get a statement on that issue from you. (We could drop a rather
large patch along with this one, if it's obsolete.) Thanks in advance!

Best regards
Manuel

Footnote:
 1. http://svn.debian.org/wsvn/pkg-openmpi/openmpi/trunk/debian/patches/10opal_noexecstack.dpatch?op=file&rev=0&sc=0